You are here: PSPad forum > Developer forum - new builds > PSPad unicode 4.5.3 (2255) English

PSPad unicode 4.5.3 (2255) English

Goto Page: Previous1 2 3 4 5 6 7 8 Next

#61 Re: PSPad unicode 4.5.3 (2255) English

Posted by: MrSpock | Date: 02/15/2007 15:35 | IP: IP Logged

MrSpock:
Do those of you who have the ctrl+tab problem have ctfmon.exe running? IE7 installed it on my system (...). After killing the process, it looks like PSPad behaves normally.

Doesn't look like ctfmon.exe is the cause: I have it running today, and PSPad has behaved as expected for several hours now.

Options: Reply | Quote | Up ^


#62 Re: PSPad unicode 4.5.3 (2255) English

Posted by: Sotho Tal Ker | Date: 02/15/2007 16:27 | IP: IP Logged

Thanks for the hint about Ctrl+click. I guess the context menu function might be obsolete now smiling smiley

Options: Reply | Quote | Up ^


#63 Re: PSPad unicode 4.5.3 (2255) English

Posted by: Eric Pement | Date: 02/15/2007 22:06 | IP: IP Logged

Regarding that bad line #150:

Quote:
$sayfa =~ s/<.*anasayfa.html"-->/$icerik/;

I don't know if you're interested in a workaround if PSPad is not fixed, but here are two:

(1) Replace the quote mark (") with an escaped hex value (\x22) - this should do it.

(2) Try closing the quote mark by adding a comment at the end of the line:

$sayfa =~ s/<.*anasayfa.html"-->/$icerik/; # "close

--
Eric

Options: Reply | Quote | Up ^


#64 Re: PSPad unicode 4.5.3 (2255) English

Posted by: bulldog | Date: 02/15/2007 22:34 | IP: IP Logged

Download is Not in English!

Options: Reply | Quote | Up ^


#65 Re: PSPad unicode 4.5.3 (2255) English

Posted by: skwire | Date: 02/16/2007 01:22 | IP: IP Logged

pspad:
skwire:
Jan, in this version, the AutoHotkey Code Explorer no longer shows functions...only labels. The previous version (4.5.3 2253) shows both properly.

Problematic source sample please

This_Is_A_Label:
{
; Do stuff here.
; Note the colon above and 'Return' below.
; Opening braces are optional as shown in
; the next Label example.
}
Return


This_Is_Another_Label:
; Do stuff here.
; Note the colon above and 'Return' below.
; No opening braces.
Return


This_Is_A_Function( param1, param2 )
{
; Note the parentheses above and the fact that
; a 'Return' is not needed for a function.
; Also, with a function, there is no space
; between the function name and opening parenthesis.
; Braces are _not_ optional.
}

I tested this out with the two versions so it should be enough to see the difference. Please let me know if it's not. Thanks!

Edited 1 time(s). Last edit at 02/16/2007 01:23 by skwire.

Options: Reply | Quote | Up ^


#66 Re: PSPad unicode 4.5.3 (2255) English

Posted by: MrSpock | Date: 02/16/2007 01:55 | IP: IP Logged

bulldog:
Download is not in English!

No, it isn't. Ever heard about localization? Maybe this link will help.

Options: Reply | Quote | Up ^


#67 Re: PSPad unicode 4.5.3 (2255) English

Posted by: Mahir | Date: 02/16/2007 10:43 | IP: IP Logged

Thanks for the advice.

I am already using the second solution like adding

#" pspad

if -any time- the problem will be solved, I'll remove all of them smiling smiley

thanks again,
Mahir

Eric Pement:
Regarding that bad line #150:

Quote:
$sayfa =~ s/<.*anasayfa.html"-->/$icerik/;

I don't know if you're interested in a workaround if PSPad is not fixed, but here are two:

(1) Replace the quote mark (") with an escaped hex value (\x22) - this should do it.

(2) Try closing the quote mark by adding a comment at the end of the line:

$sayfa =~ s/<.*anasayfa.html"-->/$icerik/; # "close

--
Eric

Options: Reply | Quote | Up ^


#68 Re: PSPad unicode 4.5.3 (2255) English

Posted by: Arne | Date: 02/17/2007 10:51 | IP: IP Logged

pspad:
Arne:
Since using PSPad 4.5.2, I have a problem when opening files from another IDE (here I can specify my editor). The file pspad.exe always gets openend in Hex mode on top of the C-file I wanted to open.

Can you confirm it with the latest 4.5.3 build?
Can you tell me command line what runs PSPad from your IDE?

I am running WinXP. The IDE is GHS Multi from Greenhills, and there one can only enter the path to the editor (and I can only enter it without ""), and then have -%LINE "%FILE0" as parameters. There are no other options. But I had PSPad installed in Prgram Files, and the space was the problem. I just don't undersdand why this did not cause any problem in version 4.5.1. I also tried the latest build, and its the same.

Thanks for the help.

Options: Reply | Quote | Up ^


#69 Re: PSPad unicode 4.5.3 (2255) English

Posted by: pspad | Date: 02/17/2007 13:06 | IP: IP Logged

Arne:
I am running WinXP. The IDE is GHS Multi from Greenhills, and there one can only enter the path to the editor (and I can only enter it without ""), and then have -%LINE "%FILE0" as parameters. There are no other options. But I had PSPad installed in Prgram Files, and the space was the problem. I just don't undersdand why this did not cause any problem in version 4.5.1. I also tried the latest build, and its the same.

Thanks for the help.

Sorry, but I am not responsible for 3rd party programs what doesn't respect Windows standard - long path have to be enclosed by quotes

Options: Reply | Quote | Up ^


#70 Re: PSPad unicode 4.5.3 (2255) English

Posted by: Fred | Date: 02/19/2007 07:44 | IP: IP Logged

Perhaps a command line option that the rest of the command line are parts of one filename?

Options: Reply | Quote | Up ^


Goto Page: Previous1 2 3 4 5 6 7 8 Next





Editor PSPad - freeware editor, © 2001 - 2014 Jan Fiala
Hosted by Webhosting TOJEONO.CZ, design by WebDesign PAY & SOFT, code Petr Dvořák