You are here: PSPad forum > English discussion forum > Assign shortcut key to browser preview

Assign shortcut key to browser preview

Goto Page: 1 2 Next

#1 Assign shortcut key to browser preview

Posted by: swbrains | Date: 2021-04-05 03:56 | IP: IP Logged

I had to reformat my PC and reinstall PSPad. In the highlighter settings for HTML files, I have set up External Programs for my 3 browsers I use to test the pages. I can't remember how to set up keyboard shortcuts like F9, CTRL+F9, etc. to launch the page from the editor in each of those browsers. I looked in Program Settings->Key Map, but I don't see entries in any of the categories for the browsers I configured. How can I do this?

Thanks!

Options: Reply | Quote | Up ^


#2 Re: Assign shortcut key to browser preview

Posted by: swbrains | Date: 2021-04-05 04:20 | IP: IP Logged

Nevermind. It seems I had to quit/restart PSPad for those browser names to appear in the Program Settings->Key Map->File section. I was then able to assign new keys to them.

Options: Reply | Quote | Up ^


#3 Re: Assign shortcut key to browser preview

Posted by: swbrains | Date: 2021-07-20 20:43 | IP: IP Logged

Apparently this really is an issue as it happened again and wasn't resolved by restarting PSPad. I re-installed PSPad and set up Edge as an external application for HTML files:

Problem #1: On one PC, I added the application path:
"C:\Program Files (x86)\Microsoft\Edge\Application\msedge.exe" "%File"
Then I realized I missed the second/ending % so I edit the entry, add the ending % after File, click Replace, click OK.
Restart PSPad, go into to edit the application path for Edge and it still shows:
"C:\Program Files (x86)\Microsoft\Edge\Application\msedge.exe" "%File"
Seems no amount of editing will let me change it. Restarted PSPad several times.

Problem #2: On another PC, after adding Edge to the external application list, it doesn't appear in the Key Map settings so I can bind it to a key. Restarted PSPad several times, but can't find Edge listed anywhere even though it is still in the HTML External Application configuration.

Any idea what I need to do to properly:
a) update an existing external application's entry
b) add a key mapping for Edge after it's added

I had all this working until I reinstalled 5.0.6 _+ 5.0.7 in order to try to solve the frequent Access Violations. Now I can't get it back to how it was... :(

Options: Reply | Quote | Up ^


#4 Re: Assign shortcut key to browser preview

Posted by: swbrains | Date: 2021-07-20 21:13 | IP: IP Logged

Additionally, I can't update the "save all files before external application start" checkbox. I check it, click OK to save, and it holds until I restart PSPad, then it's not checked any more.

Options: Reply | Quote | Up ^


#5 Re: Assign shortcut key to browser preview

Posted by: pspad | Date: 2021-07-21 04:41 | IP: IP Logged

Hello

It looks like corrupted PSPad.ini. Do you really use the current 5.0.7 build?

Options: Reply | Quote | Up ^


#6 Re: Assign shortcut key to browser preview

Posted by: pspad | Date: 2021-07-25 13:24 | IP: IP Logged

swbrains:
Problem #1: On one PC, I added the application path:
"C:\Program Files (x86)\Microsoft\Edge\Application\msedge.exe" "%File"
Then I realized I missed the second/ending % so I edit the entry, add the ending % after File, click Replace, click OK.
Restart PSPad, go into to edit the application path for Edge and it still shows:
"C:\Program Files (x86)\Microsoft\Edge\Application\msedge.exe" "%File"
Seems no amount of editing will let me change it. Restarted PSPad several times.

I tried to test it, but I wasn't sucessfull.

swbrains:
Problem #2: On another PC, after adding Edge to the external application list, it doesn't appear in the Key Map settings so I can bind it to a key. Restarted PSPad several times, but can't find Edge listed anywhere even though it is still in the HTML External Application configuration.

It doesn't appear in the keyMap. In the Keymap you see under File aRun1 .. aRun5 - highlighter tool on the position 1 to 5

Anyway, if you install WebView2 runtime (it's Edge runtime), you can use Edge in standard PSPad internal preview (F10). In this case you can switch between IE engine and Edge engine
developer.microsoft.com

Options: Reply | Quote | Up ^


#7 Re: Assign shortcut key to browser preview

Posted by: pspad | Date: 2021-07-25 14:02 | IP: IP Logged

swbrains:
Additionally, I can't update the "save all files before external application start" checkbox. I check it, click OK to save, and it holds until I restart PSPad, then it's not checked any more.

Problem with HTML/XHTML was found and fixed.

Options: Reply | Quote | Up ^


#8 Re: Assign shortcut key to browser preview

Posted by: swbrains | Date: 2021-08-02 21:00 | IP: IP Logged

I reinstalled 5.0.3 and everything was working great.

I then loaded 5.0.7 over top of it. The first thing I noticed was that when I open a Perl script (.pl file), the clip definition file doesn't appear to be loaded. I have configured CTRL+ENTER to insert a "<br>" tag, but it doesn't work.

If I choose Settings->Edit Clip Definition File from the menu and select Perl.DEF, it loads. I view it and it shows the definition of CTRL+ENTER is assigned to the text <br>. If I then load a Perl script (.pl) after viewing the .DEF file, my shortcuts work again. If I close and restart PSPad and load a .pl file, they don't work. I view the Perl.DEF file, they work. This is repeatable every time. The .DEF doesn't appear to load when I load a .pl file.

Same with my keypress F8 which was previously configured to load and run the Perl compiler on my computer. It worked fine in 5.0.3. When I load a Perl script in 5.0.7 and press F8, nothing happens. If I then load the Perl.DEF file using the "Edit Clip Definition File" menu, *then* F8 starts working to run the compiler properly again. But if I close and reopen PSPad again with a .pl file, F8 does nothing again.

What would cause all of these key mappings to not work by default but only after manually loading the .DEF file into the editor?

Thanks!

Options: Reply | Quote | Up ^


#9 Re: Assign shortcut key to browser preview

Posted by: pspad | Date: 2021-08-05 09:08 | IP: IP Logged

I just checked
Start PSpad, New / Perl
when i press Ctrl+Entr, it inserts <br /> tag - works
close PSPad

Open Perl in PSpad
when i press Ctrl+Entr, it inserts <br /> tag - works

Please check, if on the status bar is Perl when you open your file
Do you use current build?

Options: Reply | Quote | Up ^


#10 Re: Assign shortcut key to browser preview

Posted by: swbrains | Date: 2021-08-05 22:01 | IP: IP Logged

In my test here, if I open a NEW Perl document, the F8 to compile works. CTRL or SHIFT+Enter inserts the proper tags as defined in the DEF file.

However, if I start PSPad and open an EXISTING Perl document, the keypress mappings don't work. F8 does not run the compiler, and CTRL or SHIFT+Enter don't insert the tags as defined in the DEF file.

So perhaps in 5.0.7 the defined custom key mappings only get loaded with NEW files, not EXISTING.

Options: Reply | Quote | Up ^


Goto Page: 1 2 Next





Editor PSPad - freeware editor, © 2001 - 2021 Jan Fiala, Hosted by Webhosting TOJEONO.CZ, design by WebDesign PAY & SOFT, code Petr Dvořák, Privacy policy and GDPR