You are here: PSPad forum > Bug report / Hlášení chyb > Re: strange 俰؃ character after the last update

Re: strange 俰؃ character after the last update

Goto Page: 1 2 Next

#1 strange 俰؃ character after the last update

Posted by: poopiepoop | Date: 2021-04-07 20:33 | IP: IP Logged

hello,

i am sorry for such a poor bug report but i really don't know how to reproduce it :(

after the latest update occasionally when editing a file, the pspad saves this strange sequene of characters

俰؃
this has happened about 3 times so far. the original encoding of all of my files is utf-8

i have also noticed that this happens when copypasting pieces of code that have ({}) characters in them and i sometimes miss a bracket. when my compiler shows me that a weird 俰؃ character appeared and i go highlight it, it shows that i have highlighted something else/brackets instead of those weird characters and the cursor is in a slightly shifted place too

Edited 2 time(s). Last edit at 2021-04-07 20:34 by poopiepoop.

Options: Reply | Quote | Up ^


#2 Re: strange 俰؃ character after the last update

Posted by: pspad | Date: 2021-04-08 05:32 | IP: IP Logged

Thank you for report. I will test it

Options: Reply | Quote | Up ^


#3 Re: strange 俰؃ character after the last update

Posted by: bluezero | Date: 2021-04-20 14:46 | IP: IP Logged

I have the same problem, 506 and 507 versions have it.
Was working fine before. But i remember having this problem few years ago too.
image
It appears to be always the ending curly bracket }

Edited 1 time(s). Last edit at 2021-04-20 14:46 by bluezero.

Options: Reply | Quote | Up ^


#4 Re: strange 俰؃ character after the last update

Posted by: Mog | Date: 2021-04-29 06:11 | IP: IP Logged

I have also had this problem. It seems to be connected with running text diff.

Forgot: Running latest version 5.0.6 64b.

Edited 1 time(s). Last edit at 2021-04-29 06:13 by Mog.

Options: Reply | Quote | Up ^


#5 Re: strange 俰؃ character after the last update

Posted by: keen | Date: 2021-05-02 12:54 | IP: IP Logged

I have the same problem!

image

It is very unpleasant. After a little modification of the source code, part of the website stopped working for me. It took me several hours to find out what happened and why. It never occurred to me that PSPad would rewrite part of the source code to Chinese characters on its own!

Options: Reply | Quote | Up ^


#6 Re: strange 俰؃ character after the last update

Posted by: pspad | Date: 2021-05-02 13:42 | IP: IP Logged

Test please current developer build

Options: Reply | Quote | Up ^


#7 Re: strange 俰؃ character after the last update

Posted by: bluezero | Date: 2021-05-03 15:42 | IP: IP Logged

5.0.7 (600)
image

Options: Reply | Quote | Up ^


#8 Re: strange 俰؃ character after the last update

Posted by: pspad | Date: 2021-05-03 16:13 | IP: IP Logged

Current developer build is 620, not 600

Options: Reply | Quote | Up ^


#9 Re: strange 俰؃ character after the last update

Posted by: bluezero | Date: 2021-05-06 12:25 | IP: IP Logged

Appeared in 623 again:
image

Options: Reply | Quote | Up ^


#10 Re: strange 俰؃ character after the last update

Posted by: pspad | Date: 2021-05-06 12:41 | IP: IP Logged

To find problem I need more information than screenshot.
I need as much information what what was done before it as possible

Options: Reply | Quote | Up ^


Goto Page: 1 2 Next





Editor PSPad - freeware editor, © 2001 - 2021 Jan Fiala, Hosted by Webhosting TOJEONO.CZ, design by WebDesign PAY & SOFT, code Petr Dvořák, Privacy policy and GDPR