You are here: PSPad forum > English discussion forum > Blind key ` don't work properly

Blind key ` don't work properly

#1 Blind key ` don't work properly

Posted by: idefix2 | Date: 2021-06-11 11:23 | IP: IP Logged

That's a minor problem that exists maybe since I use PSPad.

With Autohotkey, I often have to use the key sequences `n and `r. After hitting the ` key, nothing happens, as the input system waits if the next character will be a vowel - in that case, it produces an single character with an accent, like à or è, in all other cases it produces the accent followed by the character typed.

At least that is how it normally works in windows. Only in PSPad, when I hit `n I get the sequence `n` and have to delete the accent following the n.

Only ` is affected, the other two accents ´ and ^ work properly.

Edited 1 time(s). Last edit at 2021-06-11 11:27 by idefix2.

Options: Reply | Quote | Up ^


#2 Re: Blind key ` don't work properly

Posted by: pspad | Date: 2021-06-11 12:03 | IP: IP Logged

Hello
It depends of the OS localization. On my keyboard when I hit `, it's written immediately, system dosn't wait for another key entry, cause in my language ` char isn't used as accent.

But the ` char is quote in programming world, same as ' or "
If you enabled Char completion in program settings / Editor, PSpad automatically inserts char couple - 2 quotes, 2 brackets and put cursor inside it.

When you switch it off, PSPad won't inserts pair of `` anymore.

Options: Reply | Quote | Up ^


#3 Re: Blind key ` don't work properly

Posted by: idefix2 | Date: 2021-06-13 15:00 | IP: IP Logged

Ok, now I understand at least where that comes from.

In autohotkey, however, ` is used as escape character. inside a string, `n for example meens linefeed. So, while I find character completion useful, just for the character ` I'd rather like to turn it off. It' not a very big deal, though, as I don't need to type ` very often.

Btw, in none of the other programming languages I work on, ` is used as quote. Maybe character completion should be dependent on the language used, for example for autohotkey, it would be nice if the percent sign was also duplicated.

Options: Reply | Quote | Up ^


#4 Re: Blind key ` don't work properly

Posted by: pspad | Date: 2021-06-13 15:35 | IP: IP Logged

I'l try to split at least in the general highlighter. If ` isn't used as string delimiter, I won't "complete" it.

Options: Reply | Quote | Up ^


#5 Re: Blind key ` don't work properly

Posted by: idefix2 | Date: 2021-06-13 19:26 | IP: IP Logged

That's great.
but don't you think it would be better (and not much more work to program) if there was an entry in the context specific .def file?

so that in pspad.ini, you have a standard entry, like
Autocompletechars=()[]{}""''``
and in every contextspecific file for every programming language there could be an optional entry which would override the standard for that language if it is present?

On AHK file, I would define
Autocompletechars=()[]{}""''%%

Edited 2 time(s). Last edit at 2021-06-13 19:32 by idefix2.

Options: Reply | Quote | Up ^






Editor PSPad - freeware editor, © 2001 - 2021 Jan Fiala, Hosted by Webhosting TOJEONO.CZ, design by WebDesign PAY & SOFT, code Petr Dvořák, Privacy policy and GDPR