You are here: PSPad forum > English discussion forum > Re: Strange characters insertion

Re: Strange characters insertion

Goto Page: Previous1 2 3 Next

#11 Re: Strange characters insertion

Posted by: pspad | Date: 2021-05-20 09:40 | IP: IP Logged

PSpad version please?

Options: Reply | Quote | Up ^


#12 Re: Strange characters insertion

Posted by: bluezero | Date: 2021-05-20 12:41 | IP: IP Logged

634, what i found in the other thread.

Options: Reply | Quote | Up ^


#13 Re: Strange characters insertion

Posted by: pspad | Date: 2021-05-21 11:34 | IP: IP Logged

Please try to disable URL highlight for testing:

Program settings / Program 2
[]Highlight URL address if no highlighter

Options: Reply | Quote | Up ^


#14 Re: Strange characters insertion

Posted by: therium | Date: 2021-05-24 10:32 | IP: IP Logged

This has happened to me in multiple versions of PSPad, like 4.x, 5.0.0, on Windows 7, and Windows 10. But it has only happened on .pl (Perl) files (since that's what I edit the most with PSPad).

Highlighter used: Perl
Completion of chars {[: not used (off)

It might only happen once every 3-6 months, after 100s of hours of editing so it can be a tricky issue to track down.

Other stuff:
I will often leave PSPad running for weeks at a time without restarting it and without rebooting my PC. I do put my PC in sleep mode every evening. I wonder if this might be a variable to look at.

Options: Reply | Quote | Up ^


#15 Re: Strange characters insertion

Posted by: bluezero | Date: 2021-05-24 18:29 | IP: IP Logged

pspad:
Please try to disable URL highlight for testing:

Program settings / Program 2
[]Highlight URL address if no highlighter

Did this on Friday, and so far all good. Will be back with report on Friday if it will not happen again till then.

Options: Reply | Quote | Up ^


#16 Re: Strange characters insertion

Posted by: bluezero | Date: 2021-05-27 09:02 | IP: IP Logged

Sadly it happened again:
image

Only thing that i can mention for today's behaviour is that PSPad crashed 2 times(first crash was reported by email).
But the #0 character appeared after fresh start.
Had 2 files opened switched to the second, copied some code, switched to the first and noticed the character.

Options: Reply | Quote | Up ^


#17 Re: Strange characters insertion

Posted by: pspad | Date: 2021-05-27 10:52 | IP: IP Logged

OK, it means it can happen "somewhere" in tabs switching. I will try to go through it

Options: Reply | Quote | Up ^


#18 Re: Strange characters insertion

Posted by: bluezero | Date: 2021-05-28 13:54 | IP: IP Logged

I was able to reproduce it today a few times, until i was not... smiling smiley

Switched tab, edited a file, saved, switched tab back and #0 was there.
Did the same. Was there again.
Then i tried the same, just without saving. Was there again.
And then tried both of the above but it did not happen again smiling smiley.

But yes, it seems to be something with switching the tabs.

Options: Reply | Quote | Up ^


#19 Re: Strange characters insertion

Posted by: SteveBondy | Date: 2021-06-07 20:48 | IP: IP Logged

For what it's worth I have also had this happen many times over many versions of PSPad and I have observed that it happens most frequently after opening and closing many files, switching back and forth between projects etc. It seems to be a buffer overflow kind of issue where data gets randomly written to the wrong place.

I've even had it corrupt my project file to the point I had to manually rebuild it.

I often have many files open so it takes a couple rows of tabs to show them all, and will run a test of the program I'm working on, open the compiler output in a new tab to review, close that, make changes and repeat. Or sometimes after doing search and replace across all files in the project so it opens and closes a bunch of files, or searching for a pattern, open the results in another tab then do another search to refine the results, etc. The common thread for me always seems to be opening and closing a lot of files.

Possibly related is that as many files are opened and closed, and the number of tabs changes from fitting on one row, to needing two rows of tabs (or back again) PSPad loses track of which tab is highlighted, so when I look at the tabs it shows one tab highlighted, but the tab actually being displayed is a different one.

I've gotten into the habit of just closing PSPad every so often when I'm opening and closing lots of files.

The vast majority of my work is editing HTML, XML, and javascript, but lately (the past 8 months or so) I have mostly been developing in Python, but I'm developing code that produces XML files.

Steve

Options: Reply | Quote | Up ^


#20 Re: Strange characters insertion

Posted by: bluezero | Date: 2021-06-08 14:21 | IP: IP Logged

image
Still happening in build 647.
On tab switching it seems, although this time i did more things that just switch the tab, was working on the other script and then came back.

Options: Reply | Quote | Up ^


Goto Page: Previous1 2 3 Next





Editor PSPad - freeware editor, © 2001 - 2021 Jan Fiala, Hosted by Webhosting TOJEONO.CZ, design by WebDesign PAY & SOFT, code Petr Dvořák, Privacy policy and GDPR