You are here: PSPad forum > English discussion forum > Strange characters insertion

Strange characters insertion

Goto Page: 1 2 3 4 Next

#1 Strange characters insertion

Posted by: pspad | Date: 2021-05-11 06:08 | IP: IP Logged

I work on strange characters insertions into code, but cause it isn't possible to simulate it, it's hard to find what is the reason.

If it happen to you, please give me information like:
used highlighter
file placement local of FTP or...

I suspect that is caused by matching brackets code. If you can switch it off for a while in Program settings / Editor 1 - Highlight matching brackets option
and report me if it happen when the code is off

And please I am interested of settings:
Program settings / Editor 1:
Completion of chars ({[<
Smart chars completion

Edited 1 time(s). Last edit at 2021-05-11 08:29 by pspad.

Options: Reply | Quote | Up ^


#2 Re: Strange characters insertion

Posted by: bluezero | Date: 2021-05-11 13:27 | IP: IP Logged

Last time it happened it was:
File extension: .php
Hihlighter: HTML Multihiglighter (not sure why it does not autodetect PHP there is no HTML inside, but that's other problem)
File source: SSH(SCP) via WinSCP
Settings:
Completion of chars ({[< On
Smart chars completion On

Options: Reply | Quote | Up ^


#3 Re: Strange characters insertion

Posted by: bluezero | Date: 2021-05-11 14:30 | IP: IP Logged

Another one today, which was a bit more changed:
image
In this case the the actual text should have bee just trailing div tag.
All the lines after were added (not replaced). Then the text continued as it was supposed to.
Notice the text "CESKY". That text is not a part of any of my scripts, so it could not have been a weird merge.

File extension: .php
Highlighter: HTML Multihighlighter
File source: SSH(SCP) via WinSCP
Settings:
Completion of chars ({[< On
Smart chars completion On

Options: Reply | Quote | Up ^


#4 Re: Strange characters insertion

Posted by: bluezero | Date: 2021-05-12 14:01 | IP: IP Logged

Similar problem.
image

In 623 we had a problem with only one character. In 625 it is adding plenty of lines.
Would appreciate if you could solve this.

Options: Reply | Quote | Up ^


#5 Re: Strange characters insertion

Posted by: pspad | Date: 2021-05-12 15:18 | IP: IP Logged

623 stopped loading when met #0 char.
625 skips #0 in files and load a rest. It looks like mani lines, but it's the same.

Options: Reply | Quote | Up ^


#6 Re: Strange characters insertion

Posted by: idefix2 | Date: 2021-05-16 10:10 | IP: IP Logged

Similar problem with AHK extension. But very rare, it happened just two times, no chance of reproducing it.

Options: Reply | Quote | Up ^


#7 Re: Strange characters insertion

Posted by: bluezero | Date: 2021-05-18 08:37 | IP: IP Logged

It keeps happening to me today very frequently.
Tell if i can enable some log, or look into a log that could help you.

Last time it happened was when i removed the line with the character, replaced it with the correct bracket, saved the file. Then switched the window to run the script. When i came back to PSPad the line was replaced with the character again.
Btw. its not just a character, then line has more than 500B.

Options: Reply | Quote | Up ^


#8 Re: Strange characters insertion

Posted by: pspad | Date: 2021-05-18 10:09 | IP: IP Logged

Used encoding?
PSpad is running and you open another file or you open PSpad with file?
Do you use PSpad in multiinstance mode?
Any such information can lead to find a problem.

Options: Reply | Quote | Up ^


#9 Re: Strange characters insertion

Posted by: bluezero | Date: 2021-05-18 10:55 | IP: IP Logged

Encoding: Unicode UTF-8 no BOM (65001)
DOS
HTML Multihighlighter
All above detected by PSPad.

First open file is opening PSPad, but the file in question is 3rd-5th being open, so PSPad is already running.

MultiInstanc=0

Options: Reply | Quote | Up ^


#10 Re: Strange characters insertion

Posted by: bluezero | Date: 2021-05-20 09:04 | IP: IP Logged

Here is another:
image
I dont remember exactly what i did, it was probably this:
Edited the file, added some code, saved it. Switched to another tab/file in PSPad. Switched back and the #0 characters were there.

Settings are the same:
Encoding: Unicode UTF-8 no BOM (65001)
DOS
HTML Multihighlighter
MultiInstanc=0

Options: Reply | Quote | Up ^


Goto Page: 1 2 3 4 Next





Editor PSPad - freeware editor, © 2001 - 2021 Jan Fiala, Hosted by Webhosting TOJEONO.CZ, design by WebDesign PAY & SOFT, code Petr Dvořák, Privacy policy and GDPR