You are here: PSPad forum > English discussion forum > Re: Loading of user highlighter colors does not work anymore

Re: Loading of user highlighter colors does not work anymore

Goto Page: Previous1 2

#11 Re: Loading of user highlighter colors does not work anymore

Posted by: pspad | Date: 2020-05-28 17:21 | IP: IP Logged

Save works, but now you must put your AutoIt highlighter into last slot. From the next build the first slow will be taken as default.
You don't need to do anything else, no manual changes in scheme file are necessary.

We have 10 slots for user highlighter and 187 syntax files. Suggest me any way how to prepare scheme files without knowledge what user highlighters are used by users.

Options: Reply | Quote | Up ^


#12 Re: Loading of user highlighter colors does not work anymore

Posted by: Professor Bernd | Date: 2020-05-29 06:17 | IP: IP Logged

Hello Jan.

I apologize very much! Yesterday I had a lot of private trouble and I was tired. Now I have slept one night and I am trying to correct my mistake: I used the terms wrong.

I wrote: User highlighter
but I meant: User Highlighter / Color Scheme

Loading and using the user highlighter works. What does not work is saving and loading the color schemes.

My question must therefore be:

In "Settings" / "Highlighter Settings" in the tab "Colors" - How can I save and load my custom color schemes as it was done in PSPad version 5.0.4 (403)?

image

I apologize once again for the confusion and hope I was able to describe it well now. smiling smiley

Bernd.

Options: Reply | Quote | Up ^


#13 Re: Loading of user highlighter colors does not work anymore

Posted by: pspad | Date: 2020-05-29 06:49 | IP: IP Logged

Professor Bernd:
My question must therefore be:

In "Settings" / "Highlighter Settings" in the tab "Colors" - How can I save and load my custom color schemes as it was done in PSPad version 5.0.4 (403)?

Put your user highlighter AutoIt to Slot 10 instead of the slot 1.
Current build takes colors from the slot 10 and save it into scheme file.

Next build will take slot 1 as default for user highlighter color schemes, so you will need to move your Autoit back to Slot 1.

There is no necessary to appologize. Sorry for troubles, but developer builds purpose is exactly this one - to find the best way.

Options: Reply | Quote | Up ^


#14 Re: Loading of user highlighter colors does not work anymore

Posted by: Professor Bernd | Date: 2020-05-29 10:07 | IP: IP Logged

pspad:
Put your user highlighter AutoIt to Slot 10 instead of the slot 1.
Current build takes colors from the slot 10 and save it into scheme file.

I made it that way and it works great for new color schemes. First I saved the current color scheme as "a_new1". Then I changed the color for "Comment" to orange and saved this color scheme as "a_new2". With "Load" I can switch between these two color schemes, I can load "a_new1" or "a_new2".

But I can't load my own color schemes anymore, which I could still load in PSPad 5.0.4 (403). Will this work again in the next build?

pspad:
Next build will take slot 1 as default for user highlighter color schemes, so you will need to move your Autoit back to Slot 1.

What about the other slots then? Do all slots have to use the same color scheme? For example, if I use "AutoIt3" in slot 1 and "Pure Basic" in slot 2, will the same color scheme be used for both languages? Can I no longer use different color schemes?

Thanks for your explanations. smiling smiley

Bernd.

Options: Reply | Quote | Up ^


#15 Re: Loading of user highlighter colors does not work anymore

Posted by: pspad | Date: 2020-05-29 10:19 | IP: IP Logged

Professor Bernd:
But I can't load my own color schemes anymore, which I could still load in PSPad 5.0.4 (403). Will this work again in the next build?

No. If you want to load it, rename color scheme section to [<not assigned>] in scheme file. Remove other [<not assigned>] sections.

Professor Bernd:
What about the other slots then? Do all slots have to use the same color scheme? For example, if I use "AutoIt3" in slot 1 and "Pure Basic" in slot 2, will the same color scheme be used for both languages? Can I no longer use different color schemes?

Yes. All user highlighters will have same color settings after loading scheme.
If you have idea, how to maintain color scheme for 180+ user languages, I am open to any idea.

Options: Reply | Quote | Up ^


#16 Re: Loading of user highlighter colors does not work anymore

Posted by: Professor Bernd | Date: 2020-05-30 19:38 | IP: IP Logged

pspad:
Yes. All user highlighters will have same color settings after loading scheme.
If you have idea, how to maintain color scheme for 180+ user languages, I am open to any idea.

Thank you very much for your trust.

For my understanding: Why not use the old system? One section in the ini file for each user highlighter slot. You don't need to handle 180+ languages, only 10 for the user highlighter slots. Or am I wrong?

Edited 1 time(s). Last edit at 2020-05-30 19:40 by Professor Bernd.

Options: Reply | Quote | Up ^


#17 Re: Loading of user highlighter colors does not work anymore

Posted by: pspad | Date: 2020-05-30 20:23 | IP: IP Logged

With the old system I need to put all user highlighters into scheme. Without it scheme file has no sense.
Even I would spend hours to prepare scheme with all highlighters provided with PSpad, there are problems:
1. user can use own highlighter not included in PSpad
2. adding new highlighter to PSpad package means update scheme files

I am sorry, but I don't have time to do it sad smiley

Options: Reply | Quote | Up ^


#18 Re: Loading of user highlighter colors does not work anymore

Posted by: Professor Bernd | Date: 2020-05-30 20:39 | IP: IP Logged

Thank you very much for your information!

You explained to me how to save and load my color schemes with the new version. smiling smiley You showed me how to change my "old" color schemes to load them. smiling smiley I can work with that.

That was very friendly and helped me.

Regards,
Bernd.

Options: Reply | Quote | Up ^


#19 Re: Loading of user highlighter colors does not work anymore

Posted by: pspad | Date: 2020-05-30 20:44 | IP: IP Logged

If you have any idea, how to handle it all todether, I am open to do it.

If you are modifying PSPad.ini, you can put section [AUTOIT3] there. But you have to do it when PSpad doesn't run.

Options: Reply | Quote | Up ^


#20 Re: Loading of user highlighter colors does not work anymore

Posted by: Professor Bernd | Date: 2020-06-01 17:04 | IP: IP Logged

pspad:
If you have any idea, how to handle it all todether, I am open to do it.

Today I studied the PSPad system, which handles color schemes. And I'm like, "Wow, this is complex!" Respect for your work!

Ok, I don't know if I can improve on that, it's really good. But maybe I can come up with an idea that will inspire your concept. I would be happy to send you my ideas.

If you want, send me a description of the task and how you want to handle the things. Maybe with rules and hints about folders and files. In the forum the notification does not work, so please send me the description by e-mail, for better communication. I am looking forward to it. smiling smiley

Regards,
Bernd.

Options: Reply | Quote | Up ^


Goto Page: Previous1 2





Editor PSPad - freeware editor, © 2001 - 2020 Jan Fiala, Hosted by Webhosting TOJEONO.CZ, design by WebDesign PAY & SOFT, code Petr Dvořák, Privacy policy and GDPR