You are here: PSPad forum > Developer forum - new builds > Re: PSPad unicode 5.0.7 (715) English

Re: PSPad unicode 5.0.7 (715) English

Goto Page: Previous1 2

#11 Re: PSPad unicode 5.0.7 (715) English

Posted by: pspad | Date: 2021-12-03 10:35 | IP: IP Logged

tmpad:
In a previous post you said you "get lot of mails each days", here you say it was "reported already".

What is your preferred way of receiving bug reports and wouldn't a public bug report system make things easier?

I had bug report before, but it costs me more time.
People doesn't search, they write same report again and again, you need to join it e.t.c.

Options: Reply | Quote | Up ^


#12 Re: PSPad unicode 5.0.7 (715) English

Posted by: PGomersall | Date: 2021-12-03 16:48 | IP: IP Logged

Jan,
I have a couple of strange issues and I am not sure if they existed in previous versions. I am running the 64 bit version of 715.

Issue 1) I open PSPad then open a several new files of different types from the "Create New File" toolbar icon. These open "properly" with the tabs visible. I then close all the open tabs either with File Close or middle clicking the tab. If I then open any new file, with the exception of TXT they open but the tabs are not visible. Only if I then open a new TXT will the tabs become visible. If I open a new TXT file first it correctly opens with a visible tab, then all other file types open correctly.

Issue 2) I was exploring Online Help on the Help menu. If I look at the default Online.ini file in another editor it's encoding is ANSI. If I use PSPad menu to navigate to Help > Online Help > Modify it opens and changes encoding ANSI default to ANSI Western European (1252). If I then edit the Online.ini file by adding say the following or even just clicking save:
[PowerShell]
PowerShell - Documentation=https://docs.microsoft.com/en-us/powershell/
;
The file is corrupted in some way as the menu no longer works correctly. The only way to fix it is to replace the Online.ini file with original. If I edit the file outside of PSPad the edits work correctly.

Regards,
Pete

Edited 1 time(s). Last edit at 2021-12-03 16:49 by PGomersall.

Options: Reply | Quote | Up ^


#13 Re: PSPad unicode 5.0.7 (715) English

Posted by: pspad | Date: 2021-12-03 18:36 | IP: IP Logged

In will investigate problems. Issue n.2 is really strange.

Options: Reply | Quote | Up ^


#14 Re: PSPad unicode 5.0.7 (715) English

Posted by: pspad | Date: 2021-12-03 19:47 | IP: IP Logged

qastrox:
Hi all
Maybe somebody already reported this issue:
This version of PSPad adds a line at the end of file when saving it, even with option "Add CR+LF to EOF" disabled.
Please, my you check?

Thanks
Nicola

Fix will be available in the next build

Options: Reply | Quote | Up ^


#15 Re: PSPad unicode 5.0.7 (715) English

Posted by: pspad | Date: 2021-12-03 20:50 | IP: IP Logged

PGomersall:
Jan,
I have a couple of strange issues and I am not sure if they existed in previous versions. I am running the 64 bit version of 715.

Issue 1) I open PSPad then open a several new files of different types from the "Create New File" toolbar icon. These open "properly" with the tabs visible. I then close all the open tabs either with File Close or middle clicking the tab. If I then open any new file, with the exception of TXT they open but the tabs are not visible. Only if I then open a new TXT will the tabs become visible. If I open a new TXT file first it correctly opens with a visible tab, then all other file types open correctly.

Issue 2) I was exploring Online Help on the Help menu. If I look at the default Online.ini file in another editor it's encoding is ANSI. If I use PSPad menu to navigate to Help > Online Help > Modify it opens and changes encoding ANSI default to ANSI Western European (1252). If I then edit the Online.ini file by adding say the following or even just clicking save:
[PowerShell]
PowerShell - Documentation=https://docs.microsoft.com/en-us/powershell/
;
The file is corrupted in some way as the menu no longer works correctly. The only way to fix it is to replace the Online.ini file with original. If I edit the file outside of PSPad the edits work correctly.

Regards,
Pete

Fix of both issues will be available in the next build

Options: Reply | Quote | Up ^


Goto Page: Previous1 2





Editor PSPad - freeware editor, © 2001 - 2022 Jan Fiala, Hosted by Webhosting TOJEONO.CZ, design by WebDesign PAY & SOFT, code Petr Dvořák, Privacy policy and GDPR