You are here: PSPad forum > Developer forum - new builds > Re: PSPad unicode 4.5.8 (2457) English

Re: PSPad unicode 4.5.8 (2457) English

#1 PSPad unicode 4.5.8 (2457) English

Posted by: pspad | Date: 2013-05-29 20:31 | IP: IP Logged

Download links (2.7 MB):
pspad.siliconhill.cz
www.dropbox.com

This archive contains modified files only. The correct way how to get all functionality:
1. Download and install latest ful version
2. Replace existing files with content of archive

Changes to 4.5.8 (2455)

News
Highlighter settings - added possibility define highlighter based current line collor
Oracle highlighter - added keywords TRIGGERS, INSTANCES, DEGREE
HTML highlighter - highlighting of pair tags DL, DT, DD
New Code explorer for Structured Text language (ftSTL file type in User highlighter definition)
Autocomplete window disappear when symbol chars is inserted

Fixes:
Hex editor - wan't possible to open file with unicode chars in name
Fixed OEM files content load
CSS inline reformat - in some cases was selector name changed to lowercase
Send unicode file name into running PSPad instance
C++ code explorer doesn't show content of NAMESPACE
Fortran code explorer - recognition of function with filetypes e.g. real*4
Run Clip function (Shift+Space) works again

Options: Reply | Quote | Up ^


#2 Re: PSPad unicode 4.5.8 (2457) English

Posted by: mceps | Date: 2013-05-30 21:58 | IP: IP Logged

Run Clip working fine now, thanks.

Thank you,
Cristian

Edited 1 time(s). Last edit at 2013-05-30 21:59 by mceps.

Options: Reply | Quote | Up ^


#3 Re: PSPad unicode 4.5.8 (2457) English

Posted by: mceps | Date: 2013-05-31 19:06 | IP: IP Logged

Hi Jan,

Actually, there's still a problem with the Run Clip in latest version, for example I have a clip entered like this:
[index | index]
index(string|,var,1)

in version 2441, if I type "in" and hit space nothing happens, the clip is not auto-run, as it shouldn't be because the clip code is "index", but in 2557 if I type "in" and hit space, or even just "i" and hit space it will auto-run this clip.

Thank you,
Cristian

Options: Reply | Quote | Up ^


#4 Re: PSPad unicode 4.5.8 (2457) English

Posted by: Freeman | Date: 2013-05-31 19:07 | IP: IP Logged

Thanks for OEM fix, Jan.

But I'm afraid it's still incomplete. Now PSPad properly opens a file with OEM block characters, but drops them on file saving. I've used these characters for an example.

Options: Reply | Quote | Up ^


#5 Re: PSPad unicode 4.5.8 (2457) English

Posted by: gwinkless | Date: 2013-06-21 15:12 | IP: IP Logged

Problem: I have always used shortcut "altS->s" to go "search"->"search in files"; now in this version when I do "altS->s", it selects the "Scripts" menu item.

My guess is that because Scripts has changed to &Scripts (instead of S&cripts (?)) windows no longer allows the ->s to choose the "&Search in files" menu item in the "Search" menu?

Options: Reply | Quote | Up ^


#6 Re: PSPad unicode 4.5.8 (2457) English

Posted by: gwinkless | Date: 2013-06-21 15:22 | IP: IP Logged

gwinkless:
Problem: I have always used shortcut "altS->s" to go "search"->"search in files"; now in this version when I do "altS->s", it selects the "Scripts" menu item.

My guess is that because Scripts has changed to &Scripts (instead of S&cripts (?)) windows no longer allows the ->s to choose the "&Search in files" menu item in the "Search" menu?

I fixed for myself by changing
mScripts_Caption=Scripts
to
mScripts_Caption=S&cripts

in Lang\English.ini

Odd thing is that previous version I had didn't have this, so I wonder if the menu handling has changed?

Edit: that's not right though, cos alt-c brings up the colour picker :(

Edited 1 time(s). Last edit at 2013-06-21 15:27 by gwinkless.

Options: Reply | Quote | Up ^


#7 Re: PSPad unicode 4.5.8 (2457) English

Posted by: Fred | Date: 2013-06-24 11:57 | IP: IP Logged

It seems that Alt+S does not drop open the Search menu.

Alt+S CR s does work but looks a little stange and different from standard behaviour...
For myself i use Alt+F for Search and replace in files ( menu Settings, Program settings, Key Map ).

Options: Reply | Quote | Up ^


#8 Re: PSPad unicode 4.5.8 (2457) English

Posted by: pspad | Date: 2013-06-24 12:12 | IP: IP Logged

There is automatic hot key assigning. It's easy to modify it and assign S for search menu.
Open .\Lang\english.ini
look for: mFind_Caption
modify it to: mFind_Caption=&Search

Options: Reply | Quote | Up ^


#9 Re: PSPad unicode 4.5.8 (2457) English

Posted by: AxeBlack | Date: 2016-03-13 10:15 | IP: IP Logged

pspad:
There is automatic hot key assigning. It's easy to modify it and assign S for search menu.
Open .\Lang\english.ini
look for: mFind_Caption
modify it to: mFind_Caption=&Search

Hi pspad, I made that change but when I click Alt+S it still doesn't bring up the search menu.

Options: Reply | Quote | Up ^


#10 Re: PSPad unicode 4.5.8 (2457) English

Posted by: pspad | Date: 2016-03-13 10:35 | IP: IP Logged

AxeBlack:
Hi pspad, I made that change but when I click Alt+S it still doesn't bring up the search menu.

When it doesn't bring up search menu, does it do anything else?
When you press ALT, you will see underscored letters in the menu. Letters must be unique.

I hope you use left Alt, cause right alt (AltGr) is Ctrl+Alt
There is possible that ALT+S is assigned to any clip or script. Loot into script menu, if there is no shortcut alt+S
Open menu settings / Clip hotkeys if there is no Alt+S shortcut

The fastest way is open TXT file (can be new one) and test it. TXT as default doesn't use code clips.

Edited 2 time(s). Last edit at 2016-03-13 10:38 by pspad.

Options: Reply | Quote | Up ^






Editor PSPad - freeware editor, © 2001 - 2019 Jan Fiala, Hosted by Webhosting TOJEONO.CZ, design by WebDesign PAY & SOFT, code Petr Dvořák, Privacy policy and GDPR