You are here: PSPad forum > Bug report / Hlášení chyb > Re: System integration failed

Re: System integration failed

#1 System integration failed

Posted by: bolfh | Date: 2019-02-04 20:39 | IP: IP Logged

Hi,

on my first attempts to install PsPad on a fresh Windows 10 system, I couldn't get the context menu integration working for a restricted (non-admin) user.

The radio buttons for "Registry" and "DLL Library" were greyed out.

After installing PsPad to a different directory ("C:\Program Files (x86)\Pspad"), context menus worked also for the restricted user.

In the registry, I still find references to non-existing short directoy names, e.g.:

[HKEY_CLASSES_ROOT\txtfile\shell\open\Command]
@="C:\\PROGRA~2\\PSPADE~1\\PSPad.exe \"%1\""

(also in HKCU\Software\Classes\txtfile\shell\open\Command)

I'm not sure whether the old installation directoy was shortened to "PSPADE~1".

Maybe an error in the generation of short path names?

I suggest not to use them anymore.

Oliver

P.S.: Sorry that I can't provide more precise observations.

Options: Reply | Quote | Up ^


#2 Re: System integration failed

Posted by: pspad | Date: 2019-02-05 05:40 | IP: IP Logged

Hello

If you want to change some settings and PSpad is installed into
Program files folder, you have to run PSPad as admin.

To fix wrong registry settings integration, switch to DLL, confirm,
switch to back to registry and confirm (or uncheck integration, confirm and set it back again)

Options: Reply | Quote | Up ^


#3 Re: System integration failed

Posted by: bolfh | Date: 2019-02-05 06:51 | IP: IP Logged

Hi,

pspad:
If you want to change some settings and PSpad is installed into
Program files folder, you have to run PSPad as admin.

as far as I see, a restricted user can invoke PSPad with "run as admin", but this affects the settings of the admin account, not the user's settings.

pspad:
To fix wrong registry settings integration, switch to DLL, confirm,
switch to back to registry and confirm (or uncheck integration, confirm and set it back again)

I found this hint and tried to do so, but switching do DLL and back to Registry was not possible since the radio buttons were greyed out in my first installation attempt.

Oliver

Options: Reply | Quote | Up ^


#4 Re: System integration failed

Posted by: pspad | Date: 2019-02-05 07:39 | IP: IP Logged

PSPad doesn't store settings into registry.
There are 2 files:
%AppData%\PSpad\PSPad.ini - user config (for portable is stored in application folder)
application folder\PSPad_MU.ini - PSpad global settings

System integration using DLL require admin rights to register DLL (COM object)
This can be done by installer or running PSPad with elevated rights

Options: Reply | Quote | Up ^






Editor PSPad - freeware editor, © 2001 - 2019 Jan Fiala, Hosted by Webhosting TOJEONO.CZ, design by WebDesign PAY & SOFT, code Petr Dvořák, Privacy policy and GDPR