You are here: PSPad forum > Bug report / Hlášení chyb > Word wrapping lines fails at the first larger file in a project

Word wrapping lines fails at the first larger file in a project

#1 Word wrapping lines fails at the first larger file in a project

Posted by: Wirek | Date: 2016-06-15 16:23 | IP: IP Logged

Hello

PSPad editor v. 4.6.1 (2714) on MS Windows XP Professional 32-bit.
I'm unhappy to report that word wrapping lines fails at the first larger file in a project while starting the editor. I have 12 files/tabs opened in my project and the larger one (200744 bytes in size, 3244 lines of code) is the 5th from the left in a line of tabs. The other files are significantly smaller than the one mentioned. When starting the editor 4 first (from the left) files/tabs have their lines correctly word wrapped but the last 8 files/tabs have their word wrapping automatically and incorrectly turned OFF (Button "Switch on or off lines wrapping (Ctrl+W)" on the button bar and menu option "View"\"Word Wrap Lines (Ctrl+W)"). Word wrapping was turned ON for all files before saving the project and closing the editor (including the program settings in "Settings"\"Program Settings..." window)!

I guess it started recently when the larger file exceeded 200000 bytes(?) in size although I have already changed the following settings in the "PSPad.INI" file (through "Settings"\"Program Settings..." menu option, "Direct edit" button, "Special settings" options group):
CodeExplorerLimit=512000
HLOnUpToSize=512000
MultiHLOnUpToSize=512000
OpenFileSizeLimit=250000000

...which helped on multihighlighter functionality (instead of silently switching to regular file type highlighter) as well as on Code Explorer functionality but not on the "Word Wrap Lines (Ctrl+W)" button functionality.

I guess it (ca. 200000 bytes limit?) is somehow hardcoded(?) in the editor instead of a configuration option (for word wrapping bytes limit) similar to those mentioned above. And what is even worse the all other files/tabs (to the right from the larger one in size) automatically opened after the 5th file/tab have the "Word Wrap Lines (Ctrl+W)" silently turned OFF also.

I don't agree "2. This is intentional, cause WordWrap on slow down speed of opening." as pspad replied to Skaurus on similar report over a year ago in thread "Two things that upset me" (forum.pspad.com) because turning it ON again for the other 8 files doesn't take long at all - it is just very annoying to do it every time the PSPad editor is started. I would understand if "Word Wrap Lines (Ctrl+W)" was automatically turned OFF only for the one actually larger file and not for 7 others too (significantly smaller). But the best solution (in my opinion) would be an additional configuration option for something like "word wrapping bytes limit" - this way everyone would be happy. I hope you can fix it.

I'm looking forward to hearing from you and... Good luck!

Options: Reply | Quote | Up ^


#2 Re: Word wrapping lines fails at the first larger file in a project

Posted by: pspad | Date: 2016-06-15 17:08 | IP: IP Logged

The file size limit 200 000 bytes for wordwrap is hardcoded.
Editor component isn't ideal for work in wordwrap mode and it slow down it.

I can move this limit to special settings. I hope it will be much better with new editor engine, but it will take some time yet.

Options: Reply | Quote | Up ^


#3 Re: Word wrapping lines fails at the first larger file in a project

Posted by: Wirek | Date: 2016-06-16 08:00 | IP: IP Logged

Thank you for your swift reply, pspad. I'm very glad to read that you can move this limit to special settings - do so, please.

Maybe the editor component isn't ideal for work in word wrap mode, but it is still very good in many cases nevertheless. It's great that it works well on quite old pieces of hardware - this PC I'm using right now is around 14 years old(!) and yet it doesn't suffer any noticeable slowdowns while starting the editor or opening files. This additional configuration option in "Special settings" group will be very helpful for many of us who prefer a little more usability to several milliseconds of load time... until you release the completely new editor with the new editor engine. winking smiley
Good luck in your project(s)!

Options: Reply | Quote | Up ^


#4 Re: Word wrapping lines fails at the first larger file in a project

Posted by: pspad | Date: 2016-06-22 08:57 | IP: IP Logged

Will be available in the next build

Options: Reply | Quote | Up ^


#5 Re: Word wrapping lines fails at the first larger file in a project

Posted by: Wirek | Date: 2016-07-11 11:39 | IP: IP Logged

A new setting "MaxWrapSize" (set to 512000 in my case instead of 200000 bytes as default value) in the section "Special settings" of the "PSPad.INI" file (through "Settings"\"Program Settings..." menu option, "Direct edit" button, "Special settings" options group) works great in the PSPad editor v. 4.6.1 (2730) on MS Windows XP Professional 32-bit!

Thank you very much, pspad, and good luck in your endeavours!

Options: Reply | Quote | Up ^






Editor PSPad - freeware editor, © 2001 - 2021 Jan Fiala, Hosted by Webhosting TOJEONO.CZ, design by WebDesign PAY & SOFT, code Petr Dvořák, Privacy policy and GDPR