You are here: PSPad forum > Bug report / Hlášení chyb > Re: Problems with charset

Re: Problems with charset

#1 Problems with charset

Posted by: toto | Date: 2016-02-04 06:36 | IP: IP Logged

Hello

I just upgrated to version 4.6 (2700) from 4.5.9 (2600) where I got problems with the charset.

After the Upgrate I opened a PHP file with FTP And saved it over ftp. I don't changed anything at the charset. After upload all € signs are resplaced with ? signs.
When I downgrated I found another issue ;)

4.5.9 working
HTML code: content="text/html; charset=iso-8859-1"
PSPad: Format=ISO 8859-2
-> € works in the browser

4.5.9 not working
HTML code: content="text/html; charset=iso-8859-2"
PSPad: Format=ISO 8859-2
-> € invisible in the browser

4.6 not working
HTML code: content="text/html; charset=iso-8859-1" or iso-8859-2
PSPad: Format=ISO 8859-2
-> instead of € a ? is visible in the browser

When I was switching the Format (UTF-8, OEM) in PSPad to find the failure and saving over FTP, PSPad changed all my € signs into ? in my PHP files angry smiley A warning like : "not all signs could be saved in this format" will be fine ;) (if this is not another failure grinning smiley)

greetings
Thorsten

Options: Reply | Quote | Up ^


#2 Re: Problems with charset

Posted by: pspad | Date: 2016-02-04 06:53 | IP: IP Logged

Hello

When you open your file, do you see chars correctly, include '€' ?
When you open your file, check code page on the statusbar.

In your FTP connection settings, is there binary transfer type? If not, FTP server manipulates with text file content.

Options: Reply | Quote | Up ^


#3 Re: Problems with charset

Posted by: Freeman | Date: 2016-02-06 23:16 | IP: IP Logged

ISO-8859-1 nor ISO-8859-2 doesn't contain the euro sign. Use ISO-8859-15 or Windows-1252 instead.

Options: Reply | Quote | Up ^


#4 Re: Problems with charset

Posted by: toto | Date: 2016-02-07 08:56 | IP: IP Logged

both are not available in PSPad ;) But good to know, I will try it

Edit: Only Windows-1252 AND iso-8859-1 works (PSPad 4.5.9)

Edited 1 time(s). Last edit at 2016-02-07 09:03 by toto.

Options: Reply | Quote | Up ^


#5 Re: Problems with charset

Posted by: toto | Date: 2016-02-07 09:53 | IP: IP Logged

pspad:
When you open your file, do you see chars correctly, include '€' ?

in PSPad 4.5.9 AND 4.6 yes

pspad:
When you open your file, check code page on the statusbar.

4.5.9 AND 4.6 iso-8859-2

pspad:
In your FTP connection settings, is there binary transfer type? If not, FTP server manipulates with text file content.

yes binary

tried another update to 4.6

always ? insted of € with all charsets in HTML + PSPad
Then I switches to tuf-8 in HTML and PSPad and it works.

Like Freeman wrote it's ok when it's not working ;) Perhabs iso-8859-1 works because of a workaround of Chrome???

greetings
Thorsten

Options: Reply | Quote | Up ^


#6 Re: Problems with charset

Posted by: toto | Date: 2016-02-07 10:19 | IP: IP Logged

OK UTF-8 is fine but the text in my Database (MySQL) is another format (PHPMyAdmin says UTF-8 Grrrrrr) so I downgrated to 4.5.9 and changed all back. I think this is my problem winking smiley

NEW PROBLEM:
I changed the PHP File in 4.6 to iso-8859-2 and saved it with FTP. All Fine in 4.6. Downgrade to 4.5.9 and all € are switched to ? !!! 4.5.9 say iso-8859-2.

I think 4.6 saves in a differtend charset then 4.5.9 ...

Options: Reply | Quote | Up ^






Editor PSPad - freeware editor, © 2001 - 2021 Jan Fiala, Hosted by Webhosting TOJEONO.CZ, design by WebDesign PAY & SOFT, code Petr Dvořák, Privacy policy and GDPR