You are here: PSPad forum > Bug report / Hlášení chyb > HTML Preview Web Server partially working.

HTML Preview Web Server partially working.

#1 HTML Preview Web Server partially working.

Posted by: johnbentley | Date: 2016-01-05 04:27 | IP: IP Logged

Bug Description:

Executing the command [HTML > HTML Preview Web Server] does not display the loaded html page, served from a settings specified web server location, on first opening PSPad. It will correctly load the page, and serve it from the specified web server, if the user visits [Settings > Program Settings ...] then subsequently runs [HTML > HTML Preview Web Server].

Steps to reproduce the bug.

1. Create a web page at C:\Users\UserName\Documents\Webroot\index.html

2. Open PSPad. Settings > Program Settings > Web Server. Fill out as follows
Server: localhost:8080
Document Root: C:\Users\UserName\Documents\Webroot

[Assuming a web server correctly configured to run at that location]

3. Close PSPad.

4. Open PSPad. Load C:\Users\UserName\Documents\Webroot\index.html into PSPad. HTML > HTML Preview Web Server. Observe the wrong Url is returned "http:///index.html" and the error message displayed is "This page can't be displayed".

5. Close the HTML Page Preview window. PSPad > Settings > Program Settings. Press Cancel (no need to change any value in the Program Settings Window).

6. HTML > HTML Preview Web Server. Observe the correct url is displayed "http://localhost:8080/index.html". You may need to hit the "Go to Page" command to load the page. Observe the page is correctly displayed.

Running:
Windows 10 Pro
PSPAD 4.6.0 (2700)

Options: Reply | Quote | Up ^


#2 Re: HTML Preview Web Server partially working.

Posted by: pspad | Date: 2016-01-05 06:08 | IP: IP Logged

Hello
If you use project, check project settings. It's possible you have some stored settings in your project and project settings has priority before common settings

Options: Reply | Quote | Up ^


#3 Re: HTML Preview Web Server partially working.

Posted by: johnbentley | Date: 2016-01-07 14:20 | IP: IP Logged

I'm not using a project.

Can you (or someone else) reproduce the bug?

Options: Reply | Quote | Up ^


#4 Re: HTML Preview Web Server partially working.

Posted by: pspad | Date: 2016-01-07 14:51 | IP: IP Logged

I will test it. Sorry, I am exhausted in my work just now and lack time for the rest as PSPad.

Options: Reply | Quote | Up ^


#5 Re: HTML Preview Web Server partially working.

Posted by: johnbentley | Date: 2016-01-08 03:07 | IP: IP Logged

No worries at all. Take care of yourself first. This is just a bug to put on the list to deal with whenever you are in a relaxed state of freedom.

Options: Reply | Quote | Up ^






Editor PSPad - freeware editor, © 2001 - 2021 Jan Fiala, Hosted by Webhosting TOJEONO.CZ, design by WebDesign PAY & SOFT, code Petr Dvořák, Privacy policy and GDPR