You are here: PSPad forum > Bug report / Hlášení chyb > Win10 FTP doesnt't work properly

Win10 FTP doesnt't work properly

Goto Page: Previous1 2 3 4 Next

#21 Re: Win10 FTP doesnt't work properly

Posted by: TerryJ72 | Date: 2016-09-16 06:02 | IP: IP Logged

Ok, So Old file listing is active, I unchecked show hidden files.
Here is the LOG:
SSL library: OpenSSL 0.9.8g 19 Oct 2007
Connecting to: ftp.xxxxxxxxxxxxxxxx.com
220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
220-You are user number 2 of 150 allowed.
220-Local time is now 05:53. Server port: 21.
220-This is a private system - No anonymous login
220-IPv6 connections are also welcome on this server.
220 You will be disconnected after 5 minutes of inactivity.
AUTH TLS
234 AUTH TLS OK.
USER xxxxxxxx
331 User xxxxxxxx OK. Password required
PASS xxxxx
230 OK. Current restricted directory is /
PBSZ 0
200 PBSZ=0
PROT P
200 Data protection level set to "private"
TYPE I
200 TYPE is now 8-bit binary
STRU F
200 F OK
MODE S
200 S OK
REST 0
350 Restarting at 0
REST 1
350 Restarting at 1
REST 0
350 Restarting at 0
Certificate: /OU=Domain Control Validated/OU=PositiveSSL Wildcard/CN=*.xxxxxxxxx.net
CWD /
250 OK. Current directory is /
TYPE A
200 TYPE is now ASCII
PASV
227 Entering Passive Mode (xxx,xx,xx,xxx,235,134)
LIST
150 Accepted data connection

SYST

TYPE A

PASV
--------------------------
Ok, So Old file listing is active, I checked show hidden files.
Here is the LOG:
SSL library: OpenSSL 0.9.8g 19 Oct 2007
Connecting to: ftp.xxxxxxxxxxxxxx.com
220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
220-You are user number 5 of 150 allowed.
220-Local time is now 06:00. Server port: 21.
220-This is a private system - No anonymous login
220-IPv6 connections are also welcome on this server.
220 You will be disconnected after 5 minutes of inactivity.
AUTH TLS
234 AUTH TLS OK.
USER xxxxxxxx
331 User xxxxxxxx OK. Password required
PASS xxxxx
230 OK. Current restricted directory is /
PBSZ 0
200 PBSZ=0
PROT P
200 Data protection level set to "private"
TYPE I
200 TYPE is now 8-bit binary
STRU F
200 F OK
MODE S
200 S OK
REST 0
350 Restarting at 0
REST 1
350 Restarting at 1
REST 0
350 Restarting at 0
Certificate: /OU=Domain Control Validated/OU=PositiveSSL Wildcard/CN=*.xxxxxxxxxx.net
CWD /
250 OK. Current directory is /
TYPE A
200 TYPE is now ASCII
PASV
227 Entering Passive Mode (xxx,xx,xx,xxx,235,117)
LIST -la
150 Accepted data connection

SYST

TYPE A

PASV

Options: Reply | Quote | Up ^


#22 Re: Win10 FTP doesnt't work properly

Posted by: pspad | Date: 2016-09-16 07:57 | IP: IP Logged

Have you tried to press LIST button in the log window as I mentioned?
Is possible to use Teamviewer session? I shpud be able to see what is going on.

Options: Reply | Quote | Up ^


#23 Re: Win10 FTP doesnt't work properly

Posted by: TerryJ72 | Date: 2016-09-16 08:06 | IP: IP Logged

Sure, We can try Teamviewer, please send me a private message with the information...

Options: Reply | Quote | Up ^


#24 Re: Win10 FTP doesnt't work properly

Posted by: nevro | Date: 2020-04-02 10:16 | IP: IP Logged

Hello. I was just wondering whether this issue was ever resolved as I seem to have exactly the same issue with my host whereby it connects OK but I do not get any file or folder listing. I noticed also that the FTP server appears to be the same (Pure FTP) and my host requires TLS. I can connect OK to this host with FileZilla and PSPAD still connects ok with my other hosts. Any help would be appreciated. Thank you.

I should also add that I've tried changing various settings (Prot P / Prot C, Passive mode, LIST etc.) but to no avail.

Excellent product BTW - thanks.

Edited 1 time(s). Last edit at 2020-04-02 10:18 by nevro.

Options: Reply | Quote | Up ^


#25 Re: Win10 FTP doesnt't work properly

Posted by: pspad | Date: 2020-04-02 10:43 | IP: IP Logged

Hello

FTP LIST command isn't standardized. Each server can have own format. Standardization comes with MLSD command.

To test if you get any file list, connect to your FTP server, show FTP log window nad press LIST button. This will bring raw list output into LOG.

Try to connect without SSL/TLS. Do you get list of files? Try LIST or MLSD. If you will get list of files, you can continue with SSL/TLS connection.
Prot C should work.

Options: Reply | Quote | Up ^


#26 Re: Win10 FTP doesnt't work properly

Posted by: nevro | Date: 2020-04-04 20:08 | IP: IP Logged

Hello and Thanks for your help.

When I press the LIST button, I get the following in the log:

SYST
TYPE A
PASV

Unfortunately as with the original poster my host does not allow connections without SSL/TLS so I'm unable to test this. Prot C doesn't appear to make any difference either.

I raised a support ticket with the host and they have replied to say they can see me connecting successfully over a secure connection and do not see any errors, but they can see that I'm logging out almost immediately after connecting:

08:47:05 polaris pure-ftpd: (?@<ipaddress>) [INFO] New connection from <ipaddress>
08:47:05 polaris pure-ftpd: (?@<ipaddress>) [INFO] TLS: Enabled TLSv1/SSLv3 with ECDHE-RSA-AES128-GCM-SHA256, 128 secret bits cipher
08:47:05 polaris pure-ftpd: (?@<ipaddress>) [INFO] <username>is now logged in
08:50:31 polaris pure-ftpd: (<username>@<ipaddress>) [INFO] Logout.

That could well be me logging out as I didn't get the file listing (I was trying various settings).

I've since tested also on another computer with PSPAD just in case, but get exactly the same issue. Again any help would be appreciated.

Thanks.

Options: Reply | Quote | Up ^


#27 Re: Win10 FTP doesnt't work properly

Posted by: nevro | Date: 2020-04-04 20:50 | IP: IP Logged

Further to my earlier post the response to the LIST was copied from an older version of PSPAD which I was testing on another PC. From the current version (5.0.3 377) the response is slightly difference (although the issue remains the same)...

SYST
215 UNIX Type: L8
TYPE A
200 TYPE is now ASCII
PASV
227 Entering Passive Mode (<ip address x,x,x,x>,207,2)

Thanks

Options: Reply | Quote | Up ^


#28 Re: Win10 FTP doesnt't work properly

Posted by: pspad | Date: 2020-04-05 05:50 | IP: IP Logged

Hello

Can you tell me how do you set keep connection option? Try to switch it off or send there at least value 20.
List button in the FTP log should send LIST or MLSD command. I don't see it in your FTP log.

Remove Show hidden files option form list command. Some server doesn't recognize it and doesn't send files list.

Options: Reply | Quote | Up ^


#29 Re: Win10 FTP doesnt't work properly

Posted by: nevro | Date: 2020-04-05 11:38 | IP: IP Logged

Hello

Firstly, thank you once again for your help it is appreciated.

The keep connection option was unchecked, although I have now tried checking it, and setting the value to 20 but still no luck. Show hidden files is also not checked.

You're correct, in that the log does not appear to show LIST or MLSD command being sent in the latest version, but in the older version 4.x it does show in the log. Here is the log from the old version (I've removed credentials, IP addresses etc. and replaced these with <xxx>) ...

SSL library: OpenSSL 1.0.2n 7 Dec 2017
Connecting to: ftp.<host domain>
220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
220-You are user number 1 of 50 allowed.
220-Local time is now 06:51. Server port: 21.
220-This is a private system - No anonymous login
220-IPv6 connections are also welcome on this server.
220 You will be disconnected after 15 minutes of inactivity.
AUTH TLS
234 AUTH TLS OK.
USER <username>
331 User <username> OK. Password required
PASS xxxxx
230 OK. Current restricted directory is /
PBSZ 0
200 PBSZ=0
PROT P
200 Data protection level set to &quot;private&quot;
TYPE I
200 TYPE is now 8-bit binary
STRU F
200 F OK
MODE S
200 S OK
REST 0
350 Restarting at 0
REST 1
350 Restarting at 1
REST 0
350 Restarting at 0
Certificate: /OU=Domain Control Validated/CN=*.<host domain>
FEAT
211-Extensions supported:
EPRT
IDLE
MDTM
SIZE
MFMT
REST STREAM
MLST type*;size*;sizd*;modify*;UNIX.mode*;UNIX.uid*;UNIX.gid*;unique*;
MLSD
AUTH TLS
PBSZ
PROT
UTF8
TVFS
ESTA
PASV
EPSV
SPSV
ESTP
211 End.
CWD /
250 OK. Current directory is /
TYPE A
200 TYPE is now ASCII
PASV
227 Entering Passive Mode (<host IP>)
MLSD
150 Accepted data connection

You can see that the MLSD command is sent, followed by the 150, and that's the end of the log. When I press the LIST button, I see the following in the log...

SYST
TYPE A
PASV

I've included the log from the current build below...

SSL library: OpenSSL 1.0.2n 7 Dec 2017
Connecting to: <host IP address>
220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
220-You are user number 7 of 50 allowed.
220-Local time is now 11:22. Server port: 21.
220-This is a private system - No anonymous login
220-IPv6 connections are also welcome on this server.
220 You will be disconnected after 15 minutes of inactivity.
AUTH TLS
234 AUTH TLS OK.
USER <username>
331 User <username> OK. Password required
PASS xxxxx
230 OK. Current restricted directory is /
PBSZ 0
200 PBSZ=0
PROT C
200 Data protection level set to "clear"
TYPE I
200 TYPE is now 8-bit binary
STRU F
200 F OK
MODE S
200 S OK
REST 0
350 Restarting at 0
REST 1
350 Restarting at 1
REST 0
350 Restarting at 0
Certificate: /OU=Domain Control Validated/CN=*.<host domain>
FEAT
211-Extensions supported:
EPRT
IDLE
MDTM
SIZE
MFMT
REST STREAM
MLST type*;size*;sizd*;modify*;UNIX.mode*;UNIX.uid*;UNIX.gid*;unique*;
MLSD
AUTH TLS
PBSZ
PROT
UTF8
TVFS
ESTA
PASV
EPSV
SPSV
ESTP
211 End.
CWD /
250 OK. Current directory is /
TYPE A
200 TYPE is now ASCII
PASV
227 Entering Passive Mode (<host IP>)

As you say, there is no record of the MLSD command here but the result is the same on both versions. When I press LIST in the log on the current version, this is what I see in the log...

SYST
215 UNIX Type: L8
TYPE A
200 TYPE is now ASCII
PASV
227 Entering Passive Mode (<host IP>)

Edited 1 time(s). Last edit at 2020-04-05 11:39 by nevro.

Options: Reply | Quote | Up ^


#30 Re: Win10 FTP doesnt't work properly

Posted by: nevro | Date: 2020-04-13 22:28 | IP: IP Logged

I'm still having no joy with this. I've just updated the computer which was running the older version of PSPAD to the latest build 5.0.3 (377) and when I view the FTP log I do see the MLSD command, but I'm still not seeing any files or folders. PSPAD works fine with my other hosting providers, but on the other hand Filezilla also connects to this host ok.

This is the log after connecting...

SSL library: OpenSSL 1.0.2n 7 Dec 2017
Connecting to: <ftp host address>
220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
220-You are user number 3 of 50 allowed.
220-Local time is now 22:25. Server port: 21.
220-This is a private system - No anonymous login
220-IPv6 connections are also welcome on this server.
220 You will be disconnected after 15 minutes of inactivity.
AUTH TLS
234 AUTH TLS OK.
USER <username>
331 User <username> OK. Password required
PASS xxxxx
230 OK. Current restricted directory is /
PBSZ 0
200 PBSZ=0
PROT P
200 Data protection level set to "private"
TYPE I
200 TYPE is now 8-bit binary
STRU F
200 F OK
MODE S
200 S OK
REST 0
350 Restarting at 0
REST 1
350 Restarting at 1
REST 0
350 Restarting at 0
Certificate: /OU=Domain Control Validated/CN=*.<domain>
FEAT
211-Extensions supported:
EPRT
IDLE
MDTM
SIZE
MFMT
REST STREAM
MLST type*;size*;sizd*;modify*;UNIX.mode*;UNIX.uid*;UNIX.gid*;unique*;
MLSD
AUTH TLS
PBSZ
PROT
UTF8
TVFS
ESTA
PASV
EPSV
SPSV
ESTP
211 End.
CWD /
250 OK. Current directory is /
TYPE A
200 TYPE is now ASCII
PASV
227 Entering Passive Mode (<IP address>)
MLSD
150 Accepted data connection

Options: Reply | Quote | Up ^


Goto Page: Previous1 2 3 4 Next





Editor PSPad - freeware editor, © 2001 - 2020 Jan Fiala, Hosted by Webhosting TOJEONO.CZ, design by WebDesign PAY & SOFT, code Petr Dvořák, Privacy policy and GDPR