You are here: PSPad forum > Bug report / Hlášení chyb > Syntax highlighting not enabled with big files

Syntax highlighting not enabled with big files

#1 Syntax highlighting not enabled with big files

Posted by: r0lZ | Date: 2015-11-27 11:32 | IP: IP Logged

I have to edit a big file, and the syntax highlighting is not automatically applied when that file is loaded in PsPad.

The file is very big (13700 lines, 518 KB). If I split it in two parts, the highlighter works as expected, so it's obviously a problem related to the size of the file.

The language of the file seems to be recognised correctly because the name of the language appears in the status bar, but the syntax is not highlighted automatically. I have to click the language name in the title bar to open the "Change syntax" dialog (where the correct language is already pre-selected) and then click OK or Cancel to force PsPad to apply the syntax highlighting.

If that matters, the language is Tcl/Tk. (I have added myself the words list and syntax definition for the Highlighter.) But if I modify slightly that file and change its extension to .c (or whatever extension recognised by PsPad), the syntax is again not highlighted by default, so it appears that its really a bug related only to the file size.

As far as I know, that bug has been introduced in v4.6.0. At least, I have never encountered it with the previous versions (but I may have edited less large files only).

Options: Reply | Quote | Up ^


#2 Re: Syntax highlighting not enabled with big files

Posted by: pspad | Date: 2015-11-27 11:43 | IP: IP Logged

Program settings / Direct edit
change value of variables:
HLUpToSize=1000000
MultiHLUpToSize=500000

Options: Reply | Quote | Up ^






Editor PSPad - freeware editor, © 2001 - 2021 Jan Fiala, Hosted by Webhosting TOJEONO.CZ, design by WebDesign PAY & SOFT, code Petr Dvořák, Privacy policy and GDPR