You are here: PSPad forum > Bug report / Hlášení chyb > PsPad textDiff doesn't show all differencies

PsPad textDiff doesn't show all differencies

#1 PsPad textDiff doesn't show all differencies

Posted by: jmartin1 | Date: 2015-11-03 12:46 | IP: IP Logged

I have 2 Unicode files. Difference in line 10 is not identified:
(Patrne je to azbukou nicmene mel jsem pocit, ze pspad podporuje Unicode - proto ho pouzivam)
Thank you for your help. Here is content of both files:
-----------------------------
Функция ПолучитьСписокИменФайлов(ГодОтчета)

НайденныеФайлы = НайтиФайлы(ПутьКаталогаОтчетов, "*.mxl");
СписокИменФайлов = Новый СписокЗначений;

Для Каждого Файл Из НайденныеФайлы Цикл
СписокИменФайлов.Добавить(Файл.ИмяБезРасширения);
КонецЦикла;

СписокИменФайлов.СортироватьПоЗначению(НаправлениеСортировки.Убыв);

КоличествоЭлементов = СписокИменФайлов.Количество();
Для Индекс = 0 По КоличествоЭлементов - 1 Цикл
Элемент = СписокИменФайлов[КоличествоЭлементов - Индекс - 1];
Попытка
ГодФайла = Число(Элемент.Значение);
Если ГодФайла > ГодОтчета Или ГодФайла < 0 Тогда
СписокИменФайлов.Удалить(Элемент);
КонецЕсли;
Исключение
СписокИменФайлов.Удалить(Элемент);
КонецПопытки;
КонецЦикла;

Возврат СписокИменФайлов;

КонецФункции
----------------------------------
Функция ПолучитьСписокИменФайлов(ГодОтчета)

НайденныеФайлы = НайтиФайлы(ПутьКаталогаОтчетов, "*.mxl");
СписокИменФайлов = Новый СписокЗначений;

Для Каждого Файл Из НайденныеФайлы Цикл
СписокИменФайлов.Добавить(Файл.ИмяБезРасширения);
КонецЦикла;

СписокИменФайлов.СортироватьПоЗначению(НаправлениеСортировки.Возр);

КоличествоЭлементов = СписокИменФайлов.Количество();
Для Индекс = 0 По КоличествоЭлементов - 1 Цикл
Элемент = СписокИменФайлов[КоличествоЭлементов - Индекс - 1];
Попытка
ГодФайла = Число(Элемент.Значение);
Если ГодФайла > ГодОтчета Или ГодФайла < 0 Тогда
СписокИменФайлов.Удалить(Элемент);
КонецЕсли;
Исключение
СписокИменФайлов.Удалить(Элемент);
КонецПопытки;
КонецЦикла;

Возврат СписокИменФайлов;

КонецФункции
----------------------------------------------------

Options: Reply | Quote | Up ^


#2 Re: PsPad textDiff doesn't show all differencies

Posted by: pspad | Date: 2015-11-03 14:16 | IP: IP Logged

Budu muset prozkoumat.

Options: Reply | Quote | Up ^






Editor PSPad - freeware editor, © 2001 - 2021 Jan Fiala, Hosted by Webhosting TOJEONO.CZ, design by WebDesign PAY & SOFT, code Petr Dvořák, Privacy policy and GDPR