You are here: PSPad forum > English discussion forum > PSPad does not highlight misspelled words in .md file

PSPad does not highlight misspelled words in .md file

#1 PSPad does not highlight misspelled words in .md file

Posted by: therium | Date: 2021-08-05 10:47 | IP: IP Logged

PSPad 5.0.6 (589) 64 bit on Windows 10. Auto spell check does not work for .md files and does not highlight misspelled words as I type them, nor when I hit enter to end a line.

A .md file is just a text file for Markdown.

- I have a clip definition file for Markdown files that I made.
- I have a highlighted I made for Markdown also so that it links to files with a .md extension. On the highlighter specification tab the File Mask is "*.md". The Filter Name is "Markdown".
- When I click Settings, User Highlighter, I do not seem to have a user highlighter definition file called Markdown.ini.
- Under Settings, Spell Settings, the dictionary I use is English.2-1-0, Show As is "Microsoft Word", Ignore One-char Words is checked, Ignore Words with Number is checked. The "Reload Dictionary" button is grayed out.
- Under the PSPad program dir\Spell I have the files English.2-1-0.dic, English.user.dic, en_dic.cab, and a few other .txt files.

Any way I get get spell checking working for .md files?

Thank you! smiling smiley

Edited 2 time(s). Last edit at 2021-08-05 10:49 by therium.

Options: Reply | Quote | Up ^


#2 Re: PSPad does not highlight misspelled words in .md file

Posted by: pspad | Date: 2021-08-05 11:11 | IP: IP Logged

Correct name is xxx.DIC, semicolon is wrong. Its plain text file with each word on separate line
In the spell settings (menu settings or ctrl+f7) is necessary select correct dictionary

Options: Reply | Quote | Up ^






Editor PSPad - freeware editor, © 2001 - 2021 Jan Fiala, Hosted by Webhosting TOJEONO.CZ, design by WebDesign PAY & SOFT, code Petr Dvořák, Privacy policy and GDPR