You are here: PSPad forum > English discussion forum > Delay at start with scripting turned on

Delay at start with scripting turned on

#1 Delay at start with scripting turned on

Posted by: Wolfgang Kiendl | Date: 2021-07-05 14:19 | IP: IP Logged

I have a delay of several seconds when starting PSPad with a very short file. The file appears quickly, but what I type doesn't appear until about 7 seconds later.

It does depend on scripting being turned on, but I need scripting, so turning it off is not a option. I also tried to installed it into a directory not covered by the virus scanner, but this doesn't change anything.

Then I did an analysis using the Process Monitor from SysInternals:

Without scripting: The closing of the PsPad\phpCBcfg.ini is immediately followed by querying HKLM\System\CurrentControlSet\Control\Notifications\418A073AA3BC8075.

With scripting: After closing the PsPad\phpCBcfg.ini, there is a load image of C:\Windows\SysWOW64\coml2.dll and then there are a lot of registry keys queried:
1. Check HKCU\Software\Classes
2. Enumerate HKCR\PackagedCom\ClassIndex followed by HKCR\PackagedCom\ClassIndex\{hex-value} accesses with different hex values and more keys because of that, but it is only about 40ms in total.
3. Enumerate HKCU\Software\Classes\WOW6432Node\CLSID. But this seems to be just once, so maybe there is no content. Or maybe it runs concurrently with 4.
4. Enumerate HKCR\WOW6432Node\CLSID. This goes on for almost 5 seconds with the following sub entries:
4.1. HKCU\Software\Classes
4.2. HKCU\Software\Classes\WOW6432Node\CLSID\{<hex value>} (not found)
4.3. HKCR\WOW6432Node\CLSID\{<same hex value>} (found)
4.4 HKCR\WOW6432Node\CLSID\{<same hex value>}\Implemented Categories\{<other hex value>} (not found)
5. No more entries of HKCR\WOW6432Node\CLSID and closing of the same.
6. Closing of several other key.
7. Closing of HKCU\Software\Classes\WOW6432Node\CLSID.
8. Querying of PsPad\Script\JScript and other sub-directories of Script and some other registry keys taking only about 8 ms.
9. Querying HKLM\System\CurrentControlSet\Control\Notifications\418A073AA3BC8075 as above.

So IMHO it is quite obvious that the problem is in step 4 i.e. enumerating HKCR\WOW6432Node\CLSID and maybe HKCU\Software\Classes\WOW6432Node\CLSID, as far as I can see for no positive effect, since it doesn't seem to find anything.

Only I have no idea what is causing it and what to do against it. Googling for the COML2.DLL that might or might not be related to it, didn't make me any wiser.

Any suggestions?

Data about environment:
- Fresh install of PSPad, no configurations changes made.
- Version 5.0.6 (589) 32 Bit (since scripting doesn't seem to work with 64 bit)
- Also tried developer version, no change.

Best Regards,
Wolfgang Kiendl

Edited 1 time(s). Last edit at 2021-07-05 14:25 by Wolfgang Kiendl.

Options: Reply | Quote | Up ^

Editor PSPad - freeware editor, © 2001 - 2024 Jan Fiala, Hosted by Webhosting TOJEONO.CZ, design by WebDesign PAY & SOFT, code Petr Dvořák, Privacy policy and GDPR