You are here: PSPad forum > English discussion forum > Weird highlighting problem

Weird highlighting problem

#1 Weird highlighting problem

Posted by: bluezero | Date: 2018-12-28 14:39 | IP: IP Logged

I noticed some weird highlighting problem when selecting some part of the code then the syntax is wrongly highlighted, here is an example:

Before:
i.gyazo.com

After (PHP):
i.gyazo.com

After (HTML Multihighlighter):
i.gyazo.com

I did not have the problem in 4.x.x, only in 5.x.x

Hope you will be able to fix it.

Thank you

Edited 1 time(s). Last edit at 2018-12-28 14:39 by bluezero.

Options: Reply | Quote | Up ^


#2 Re: Weird highlighting problem

Posted by: pspad | Date: 2018-12-28 22:38 | IP: IP Logged

Hello

There is combination with highlighting syntax, highlighting cuttent line and selecting text.

I don't see nothing wrong. Can you exactly write what do you consider as wrong highlighting and how it should be in your oopinion?

Options: Reply | Quote | Up ^


#3 Re: Weird highlighting problem

Posted by: bluezero | Date: 2018-12-29 15:37 | IP: IP Logged

Hi,

look at the commented out code, beginning from line 606.
Its correct on the first image, but not correct on the 2nd and 3rd.
The only difference I made is the selected variable on line 600, then the commented out code changed the color.

Options: Reply | Quote | Up ^






Editor PSPad - freeware editor, © 2001 - 2019 Jan Fiala, Hosted by Webhosting TOJEONO.CZ, design by WebDesign PAY & SOFT, code Petr Dvořák, Privacy policy and GDPR