You are here: PSPad forum > Developer forum - new builds > PSPad unicode 5.0.0 (261) English

PSPad unicode 5.0.0 (261) English

Goto Page: Previous1 2 3 4 5 6 Next

#21 Re: Open file with mouse click in explorer not possible

Posted by: pspad | Date: 02/19/2018 13:48 | IP: IP Logged

khagaroth:
I'm getting message sent dialogs with the full file path, but no message received dialogs at all.

Please start registry editor and check:
\HKEY_CURRENT_USER\Software\PSPad
there should be PSPadHandle variable with numeric value (different each PSPad start). It's temporary main PSPad instance handle.
This value is used as message receiver.

Options: Reply | Quote | Up ^


#22 Re: Open file with mouse click in explorer not possible

Posted by: AndreasW | Date: 02/19/2018 13:52 | IP: IP Logged

pspad:
Please start registry editor and check:
\HKEY_CURRENT_USER\Software\PSPad
there should be PSPadHandle variable with numeric value (different each PSPad start). It's temporary main PSPad instance handle.
This value is used as message receiver.

Confirmed.

Options: Reply | Quote | Up ^


#23 Re: Open file with mouse click in explorer not possible

Posted by: AndreasW | Date: 02/19/2018 13:58 | IP: IP Logged

By the way, deleting PSPad_MU.INI does not solve the problem for me.

Options: Reply | Quote | Up ^


#24 Re: Open file with mouse click in explorer not possible

Posted by: khagaroth | Date: 02/19/2018 13:59 | IP: IP Logged

The registry value is there. Changes after each program restart.

Options: Reply | Quote | Up ^


#25 Re: Open file with mouse click in explorer not possible

Posted by: ivo | Date: 02/19/2018 14:04 | IP: IP Logged

AndreasW:
By the way, deleting PSPad_MU.INI does not solve the problem for me.

For me, deleting PSPad_MU.INI appears "Message received" dialog, and PSPad works as previous versions.

Options: Reply | Quote | Up ^


#26 Re: Open file with mouse click in explorer not possible

Posted by: pspad | Date: 02/19/2018 14:10 | IP: IP Logged

What I tested and works for me with x32 PSPad
Windows 10 x64 - tested Multiuser 1/0 (multiuser has no influence)
Windows 7 x64

In both cases I see message send and message receive
I tried to run PSPad from "network". There was question for the first instance start, but another file opening with context menu was without problem.

I am little confused. I need to find a cause or rewrite whole file handling.

Options: Reply | Quote | Up ^


#27 Re: Open file with mouse click in explorer not possible

Posted by: pspad | Date: 02/19/2018 14:13 | IP: IP Logged

ivo:
Same problem here, with TotalCommander.
I suspect it's related with Multi User Environment (and PSPad_MU.ini)
I tried to shift out that file (from pspad folder), then closing PSPad and all was ok.
Trying again with PSPad_MU, problem reappears.
I hope it helps
Bye
Ivo

for me the PSPad_MU.ini in the PSPad folder contains:
[Config]
MultiUser=1
MultiInstanc=0
ShowSplash=0
PlainContextMenu=0

Options: Reply | Quote | Up ^


#28 Re: Open file with mouse click in explorer not possible

Posted by: AndreasW | Date: 02/19/2018 14:23 | IP: IP Logged

pspad:
for me the PSPad_MU.ini in the PSPad folder contains:
[Config]
MultiUser=1
MultiInstanc=0
ShowSplash=0
PlainContextMenu=0

My PSPad_MU.ini looks as follows:

[Config]
MultiUser=0
MultiInstanc=0
ShowSplash=1
PlainContextMenu=0

I tried it also with your PSPad_MU.ini, but that didn't change anything (i.e. the problem still occurs).

Options: Reply | Quote | Up ^


#29 Re: Open file with mouse click in explorer not possible

Posted by: pspad | Date: 02/19/2018 14:25 | IP: IP Logged

AndreasW:
I tried it also with your PSPad_MU.ini, but that didn't change anything (i.e. the problem still occurs).

Because from my point of view the only thing what have influence is Multiinstanc variable.
The first (Multiuser) determines config files placement only.

Please check, if you don't start PSPad in any compatibility mode.

Edited 1 time(s). Last edit at 02/19/2018 14:26 by pspad.

Options: Reply | Quote | Up ^


#30 Re: Open file with mouse click in explorer not possible

Posted by: AndreasW | Date: 02/19/2018 14:28 | IP: IP Logged

pspad:
Please check, if you don't start PSPad in any compatibility mode.

I don't start PSPad in any compatibility mode.

By the way, my OS is Windows 7 Professional x64.

Options: Reply | Quote | Up ^


Goto Page: Previous1 2 3 4 5 6 Next





Editor PSPad - freeware editor, © 2001 - 2018 Jan Fiala, Hosted by Webhosting TOJEONO.CZ, design by WebDesign PAY & SOFT, code Petr Dvořák, Privacy policy and GDPR