You are here: PSPad forum > Bug report / Hlášení chyb > "find" not working correctly

"find" not working correctly

#1 "find" not working correctly

Posted by: Macari | Date: 12/08/2015 17:32 | IP: IP Logged

Hello.

When I try to search a word, than once in a while its not go to next result, but jump from beginning to end of file, to middle and back to beginnung of file....

Example: I search "word", from top of file

line 2: word
line 5: word
line 7: word
line 9: word

expected result is line 2, 5, 7 and at last 9.

but result in pspad (v2703) is 5, 2, 9, 7. Its found all, but not in one direction. Its jump random in the file.

Options: Reply | Quote | Up ^


#2 Re: "find" not working correctly

Posted by: pspad | Date: 12/08/2015 19:03 | IP: IP Logged

It isn't possible it jumps randomly. How do you did search next?

Options: Reply | Quote | Up ^


#3 Re: "find" not working correctly

Posted by: Macari | Date: 04/26/2017 10:57 | IP: IP Logged

In latest version 5 (187) this still happen too.

I press STRG+F type search string in box. Its very very rare, but its happen that its jump partly random in file. Thats not a joke. ;)

EDIT:

I can reproduce it. test text:

texta textb textc textd texte texta textb textc textd texte texta textb textc textd texte
texta textb textc textd texte texta textb textc textd texte
texta textb textc textd texte texta textb textc textd texte
texta textb textc textd texte texta textb textc textd texte texta textb textc textd texte

1. I have a text in clipboard for replace search-text
2. STRG+F, type "texta" in dialog and start search
3. "texta" is selected and with STRG+V(SHIFT+INSERT) i replace "texta" with "testABC" (from clipboard)
4. press F3 for search next "texta" for replacing
5. after few F3 and replacing text its jump to end of text and beginning next F3 from top of the text.

Maybe this helps?

Edited 4 time(s). Last edit at 04/26/2017 11:03 by Macari.

Options: Reply | Quote | Up ^


#4 Re: "find" not working correctly

Posted by: Andreas | Date: 04/26/2017 11:04 | IP: IP Logged

I can not confirm for 186.

Options: Reply | Quote | Up ^


#5 Re: "find" not working correctly

Posted by: Macari | Date: 04/26/2017 11:30 | IP: IP Logged

As I said before, it does not always happen. I can, however, with several attempts so reproduce. Here a screen

www2.pic-upload.de

here a second test. (last found I don't replace, its only selected)

www2.pic-upload.de

Edited 1 time(s). Last edit at 04/26/2017 11:35 by Macari.

Options: Reply | Quote | Up ^


#6 Re: "find" not working correctly

Posted by: Andreas | Date: 04/26/2017 11:48 | IP: IP Logged

Tested another 6 times. Can not confirm.

For now you can use the replace function with "confirm replacement".

Options: Reply | Quote | Up ^






Editor PSPad - freeware editor, © 2001 - 2017 Jan Fiala
Hosted by Webhosting TOJEONO.CZ, design by WebDesign PAY & SOFT, code Petr Dvořák