You are here: PSPad forum > English discussion forum > How can I stop all autocompletion?

How can I stop all autocompletion?

#1 How can I stop all autocompletion?

Posted by: jack2017 | Date: 08/18/2017 13:35 | IP: IP Logged

I can't seem to turn off autocomplete.

I have autocomplete delay set to 0
Completeion of chars ({[<"' is unchecked
Have I missed a setting?

When typing into a PHP text file autocomplete is still active
Worse still it tries to insert PHP keywords and also does this
in lines started as comments.

How can I turn off all auto-complete and any auto-suggest functions
everywhere?

This is driving me crazy yawning smiley

thank you

Options: Reply | Quote | Up ^


#2 Re: How can I stop all autocompletion?

Posted by: pspad | Date: 08/18/2017 17:07 | IP: IP Logged

Hello

Autocompete delay = 0 stops popup window with autocomplete. You can call it with Ctrl+J
Complete brackets stops auto inserting brackets.
There is manual script insert with Ctrl+Space, but it is called manually.
There is no other autocompletion.

Maybe you installed some scripts what did additional autocompletion. What exactly is autocompleted for you?

Options: Reply | Quote | Up ^


#3 Re: How can I stop all autocompletion?

Posted by: jack2017 | Date: 08/22/2017 16:42 | IP: IP Logged

Hi thanks for the response

As an example:

If I open a PHP file and edit it I could type in

// at least 1 full record is required IN each

After typing the word "each" pspad inserts (TABarray array)

making the line read:
// at least 1 full record is required IN each(TABarray array)

There are many others including curly brackets and so on inserted depending
on what is typed. It doesnt seem to occur if you cut/paste it - you must type it
AND it doesnt do it in empty files - it seems file content dependent and doesnt
do it to order - ie. I cant always reproduce it without typing a while (buffer issues??).

However it always does something similar after typing for a while.

I hope you can reproduce that but you may have to edit some PHP files to do it.
(I cant make it do it myself again at the moment but that is a real example)

I just typed into another PHP file the line:

// and now I print

and it spat out '(string arg)'
giving the line :

// and now I print(string arg)

I think this may be related to PHP keywords?

john.

Options: Reply | Quote | Up ^


#4 Re: How can I stop all autocompletion?

Posted by: pspad | Date: 08/22/2017 19:57 | IP: IP Logged

Hello

Does it happen if you switch off printing support? PSpad doesn't contains such functionality and I didn't find it in code clips too.

Please download 4.6.2 portable version (zip)
Unpack it into any folder and run PSPad from there.
Try to repeat your steps.

Options: Reply | Quote | Up ^






Editor PSPad - freeware editor, © 2001 - 2017 Jan Fiala
Hosted by Webhosting TOJEONO.CZ, design by WebDesign PAY & SOFT, code Petr Dvořák