You are here: PSPad forum > English discussion forum > charset problem if i save with pspad

charset problem if i save with pspad

#1 charset problem if i save with pspad

Posted by: erkange | Date: 02/04/2017 08:05 | IP: IP Logged

Hello,

I provide product content to my customers.
I gave them only content part of with html. I don't provide whole page with charset etc.

If i save the code with pspad, we can't see turkish letters well.
Like; www.betaplus.com.tr

But if i copy same code from pspad and past to microsoft expression, i can see the page like i want.
like; www.betaplus.com.tr

When i check the code, it is exactly same. How come this happen?
Ho i can continue to work with pspad (i like it) but save like ms expression?

Please see screenshot in below;

image

Options: Reply | Quote | Up ^


#2 Re: charset problem if i save with pspad

Posted by: vbr | Date: 02/04/2017 12:51 | IP: IP Logged

Hi,
it is likely, that your other editor is adding byte-order-mark (BOM) at the beginning of the utf-8 file and your browser relies on it to determine the encoding of the page (in absence of the usual meta-tag).
You can try the same setting in PSPad - check the respecitve item in settings:
[x] Settings: Program (part 2): Ident. bytes in UTF-8 coding

and resave the file as utf-8.
(You can check this mark in the hexadecimal view of the file - in PSPad - File: Open in hex Editor...

hth,
vbr

Options: Reply | Quote | Up ^


#3 Re: charset problem if i save with pspad

Posted by: erkange | Date: 02/04/2017 19:54 | IP: IP Logged

vbr:
Hi,
it is likely, that your other editor is adding byte-order-mark (BOM) at the beginning of the utf-8 file and your browser relies on it to determine the encoding of the page (in absence of the usual meta-tag).
You can try the same setting in PSPad - check the respecitve item in settings:
[x] Settings: Program (part 2): Ident. bytes in UTF-8 coding

and resave the file as utf-8.
(You can check this mark in the hexadecimal view of the file - in PSPad - File: Open in hex Editor...

hth,
vbr

thx alot. You saved my day. Thank you smiling smiley

Options: Reply | Quote | Up ^


#4 Re: charset problem if i save with pspad

Posted by: Andreas | Date: 02/05/2017 14:48 | IP: IP Logged

This is not a good solution to set a BOM into your files. Simply set your default CodePage to UTF-8. Additionaly in your file under "Format" check that UTF-8 is marked. Type in your Turkish chars. Save.

Example with german special chars public.andreasburg.de

Also make sure that your HTML-pages contain only valid HTML validator.w3.org

Options: Reply | Quote | Up ^






Editor PSPad - freeware editor, © 2001 - 2017 Jan Fiala
Hosted by Webhosting TOJEONO.CZ, design by WebDesign PAY & SOFT, code Petr Dvořák