You are here: PSPad forum > English discussion forum > Re: File opens in HEX-mode

Re: File opens in HEX-mode

#1 File opens in HEX-mode

Posted by: tjokkis_ii | Date: 08/16/2012 10:30 | IP: IP Logged

I have some text(?) files that since version 4.5.6 always opens in HEX-mode. They opens and looks fine in notepad and other text editors, and was always treated as text in PSPad before I upgraded to 4.5.6.

Is there a way I can force PSPad to open files as text?

Options: Reply | Quote | Up ^


#2 Re: File opens in HEX-mode

Posted by: pspad | Date: 08/16/2012 12:19 | IP: IP Logged

PSPad has reason if he open file in HEX mode. I guess your file contains some nonprinted chars from the begin of ASCII table.
You can switch off binnary file detection.
Go to Program settings / Direct edit button
Change variable of: AutodetectBinnary=0

Options: Reply | Quote | Up ^


#3 Re: File opens in HEX-mode

Posted by: tjokkis_ii | Date: 08/16/2012 15:04 | IP: IP Logged

It was a handful of white spaces at the start of the file.

Changing the setting solved my problem, thanks a lot.

Can I comment out lines in "Direct edit"?
(I like to keep a copy of the original values, both to remember what I have edited manually and the default value.)

Options: Reply | Quote | Up ^


#4 Re: File opens in HEX-mode

Posted by: pspad | Date: 08/16/2012 17:08 | IP: IP Logged

You can. But you can delete line - this will reset setting to it's original value.

Options: Reply | Quote | Up ^






Editor PSPad - freeware editor, © 2001 - 2014 Jan Fiala
Hosted by Webhosting TOJEONO.CZ, design by WebDesign PAY & SOFT, code Petr Dvořák