You are here: PSPad forum > English discussion forum > Re: MinGW highlighter settings

Re: MinGW highlighter settings

#1 MinGW highlighter settings

Posted by: Thistleknot | Date: 06/01/2012 19:42 | IP: IP Logged

First, I had to edit
pspad's
makefile.ini
add *.win to filetype

then to setup minigw...

I read this
gogogadgetscott.info

Why cmd.exe? Why do all the other instructions say gcc.

Also, the /C doesn't work for path...

then tried this
gogogadgetscott.info

didn't work

then I read this

see x
bogdan-computer.x.com
x= b l o g s p o t (word is banned I guess)

and made my settings look like this

(I even had a path variable set to point to the \bin folder), I'd prefer a path variable set using the gcc options though.

compiler
F:\Dev-Cpp\MinGW64\bin\gcc.exe

param's
"%File%" -o "%Dir%%Name%.exe" -L"F:/Dev-Cpp/MinGW64/x86_64-w64-mingw32/lib" -I"F:/Dev-Cpp/MinGW64/x86_64-w64-mingw32/include" -I"F:/Dev-Cpp/MinGW64/x86_64-w64-mingw32/include" -L"-L"F:/Dev-Cpp/MinGW64/x86_64-w64-mingw32/lib" -I"F:/Dev-Cpp/MinGW64/"

default dir
F:\dev

logfile
%F:%L:*

run after
"%DIR%%NAME%.exe"

yet, I still keep getting "undefined reference to 'std::cout'" ...

Edited 9 time(s). Last edit at 06/01/2012 20:13 by Thistleknot.

Options: Reply | Quote | Up ^


#2 Re: MinGW highlighter settings

Posted by: Thistleknot | Date: 06/01/2012 20:54 | IP: IP Logged

this fixed it

this got rid of a dll error (after going to 32 bit), but still getting cout errors
default dir:
F:\Dev-Cpp\MinGW32\bin

this fixed it
compiler:
F:\Dev-Cpp\MinGW32\bin\g++.exe

Options: Reply | Quote | Up ^






Editor PSPad - freeware editor, © 2001 - 2014 Jan Fiala
Hosted by Webhosting TOJEONO.CZ, design by WebDesign PAY & SOFT, code Petr Dvořák