You are here: PSPad forum > České diskuzní fórum > Chyba načítania textu do bloku pri vyhľadávaní

Chyba načítania textu do bloku pri vyhľadávaní

#1 Chyba načítania textu do bloku pri vyhľadávaní

Posted by: Restorator | Date: 12/14/2016 15:22 | IP: IP Logged

Zdravim...

Uz parkrat sa mi v poslednej developer verzii 4.6.2(2735) objavila chyba pri vyhladavani textoveho retazca v subore s priponou *.ini. K hlavnej verzii sa vyjadrit momentalne neviem, pretoze tuto chybu som doposial neregistroval.

V subore na urcitom riadku som mysou natiahol do bloku urcity text v riadku, ktory som chcel vyhladat v otvorenych suboroch, avsak namiesto danej zvyraznenej casti textu v riadku mi nacitalo do vyhladavania iny text z predosleho vyssieho riadku, ktory som uz vyhladal. Nie je to chyba toho, ze by mi v schranke v pamäti zostal iny text, pretoze som si obsah pamäte vlozil do poznamkoveho bloku a nacitany text suhlasil s vyberom.

vid. screen

postimg.org

Riadky medzi zalozkou (vratane riadku so zalozkou) a zvyraznenym textom mi nacitalo do vyhladavania spravne.

--
Windows 7 Professional x64, SP1
PSPad 4.6.2 (2735)

Options: Reply | Quote | Up ^


#2 Re: Chyba načítania textu do bloku pri vyhľadávaní

Posted by: pspad | Date: 12/14/2016 15:43 | IP: IP Logged

Podívám se na to

Options: Reply | Quote | Up ^


#3 Re: Chyba načítania textu do bloku pri vyhľadávaní

Posted by: Restorator | Date: 12/14/2016 16:00 | IP: IP Logged

Vsimol som si, ze oznaceny text do bloku, ktory mi nacitalo do vyhladavania nespravne, je zhodny s castou textu pri zalozke. Pride mi to laicky tak, akoby si program pamätal, ze takuto cast textu oznacenu do bloku uz mal vo vyhladavacom poli a ponukol mi predosly vyraz, zhodou okolnosti v riadku so zalozkou.

--
Windows 7 Professional x64, SP1
PSPad 4.6.2 (2735)

Options: Reply | Quote | Up ^


#4 Re: Chyba načítania textu do bloku pri vyhľadávaní

Posted by: Restorator | Date: 12/20/2016 05:05 | IP: IP Logged

Este by som chcel dodat, ze pri prekladoch programov dost casto vyhladavam urcite vyrazy oznacenim do bloku:

napr.

GrayScale=

Ak vyznacim do bloku oblast textu bez uvodzoviek "GrayScale", tak do vyhladavacieho pola mi vpise "grayscale", cize text s nespravne opoznanou velkostou znakov. Znaky musim potom prepisovat, aby som mohol zadat dalsi parameter vyhladavania, napr. rozlisovat velkost pismen, inak vyhladavanie nesplni dany ucel.

.. ALE ..

Ak vyznacim oblast "GrayScale=", text sa skopiruje do vyhladavacieho pola spravne.

Skusal som nasimulovat vyznacovanie tak, ze som si pod seba dal tieto tri vyrazy a oznacoval som ich ci uz mysou alebo cez klavesy Shift + sipka jednotlivo do bloku v riadku:

grayscale=
GrayScale=
GrAyScaLe=

- bez znaku "=" skopiruje stale len vyraz "grayscale" s malymi znakmi a to v hocijakom poradi
- so znakom "=" skopiruje vzdy spravny vyraz a to v hocijakom poradi

--
Windows 7 Professional x64, SP1
PSPad 4.6.2 (2735)

Edited 2 time(s). Last edit at 12/20/2016 05:06 by Restorator.

Options: Reply | Quote | Up ^






Editor PSPad - freeware editor, © 2001 - 2017 Jan Fiala
Hosted by Webhosting TOJEONO.CZ, design by WebDesign PAY & SOFT, code Petr Dvořák